01304 827609 info@use-ip.co.uk Find us

Hik-Connect Alarm Notifications IVMS-4500

Rob

New Member
Messages
9
Points
3
I have a DS-7604NI-E1/4P and have been utilizing it over my local area network (IP Domain). No issues for a couple years - just recently my alarm notifications stopped coming through the IVMS-4500 app. The DVR is capturing the alarms and can produce an audible alarm, but nothing is coming to the iphone on the IVMS-4500 app. I have checked that alarm notifications are on, notifications are turned on phone, deleted and re-input the line crossing alarms (was sure to check off "notify surveillance center), rebooted the DVR, deleted and redownloaded IVMS-4500 and still nothing. I even tried rebooting my TP-link router. I am able to see the live cameras and recordings on the IVMS-4500, just no alarm notifications.

Any thoughts out there on what may be happening? I appreciate any help you can provide!
 
Solution
...and just like that (July 22, 2021) the smart event line crossing push notifications are now working. Changed nothing on my end. There were no IVMS_4500 app updates for IoS, so what made it work? I have to assume somewhere (wherever the server is) there was a fix. While I am glad they are now working again, I would really like to know what the reason is for the issue - certainly was not on my end.

Rob

New Member
Messages
9
Points
3
Update - I discovered all 4 of my PoE ports indicating PoE overload (message looks like it has been occurring for months) - pretty sure something inside the NVR is bad. Every port shows 3059.1W for a total of 12236.5W. Entire system had been working flawlessly for over a year. I don't think there was any sort of power surge since NVR is tied into a surge suppressor.
 
Upvote 0

Rob

New Member
Messages
9
Points
3
Update - received NVR back from Hikvision. There was a bad main board which was causing the poe overload - they replaced the board. Unfortunately, the line crossing alarm alerts still do not come through to the IVMS-4500 app. Very frustrating since I know I have them set up correctly - so remains a mystery to me what is causing this.

As an aside, I found it interesting the equipment came back with a firmware build that is not the most current and isn't even listed as on "older version" on the website (close but not exact on the build #) . I am afraid to update to the most current since I am wondering if they technician knows something about the firmware that may have contributed to the poe overload.

Any thoughts out there from anyone?
 
Upvote 0

JB1970

Well-Known Member
Messages
869
Points
63
Update - received NVR back from Hikvision. There was a bad main board which was causing the poe overload - they replaced the board. Unfortunately, the line crossing alarm alerts still do not come through to the IVMS-4500 app. Very frustrating since I know I have them set up correctly - so remains a mystery to me what is causing this.

As an aside, I found it interesting the equipment came back with a firmware build that is not the most current and isn't even listed as on "older version" on the website (close but not exact on the build #) . I am afraid to update to the most current since I am wondering if they technician knows something about the firmware that may have contributed to the poe overload.

Any thoughts out there from anyone?
For the alarms you may have to use the Hik Connect app. Unfortunately, unlike iVMS-4500, the NVR needs to be registered/connected with Hik Connect for the notifications to work (with iVMS-4500 where you could connect by IP/Domain and have them work). There was a user on the IPCam Talk forum the other day having similar issues with iVMS 4500 - he was no longer receiving notifications for hard wired NVR alarm inputs with no obvious reason why. Not sure whether this could be due to a change in the app or maybe even something in the phone operating system - iOS.

I wouldn't have any concerns about loading the latest firmware. What is the full model number of your NVR and what is the firmware version and build number they've put on it?
 
Upvote 0

Rob

New Member
Messages
9
Points
3
Thank you for your response.
My NVR is Hikvision DS-7604NI-E1/4P and firmware V3.4.96 build 171128 was loaded when it came back after they replaced the main board.
I am in the U.S. and the Hikvision website shows v3.4.96 build 181107 as the last best build for the NVR model - that's what it had on it when I sent it in for repair.
As mentioned, I am afraid to update to the most current since I am wondering if the technician knows something about the firmware that may have contributed to the poe overloads.
The lack of the alarm pushes is really disappointing - can see the cameras and playback video on the IVMS-4500 but not alarm push alerts.
Thanks again for thoughts on this.
 
Upvote 0

JB1970

Well-Known Member
Messages
869
Points
63
For that NVR the latest firmware in the European download portal is 3.4.98_171121 and in the UK portal it is 3.4.106_191009. Unfortunately I'm not sure whether there are differences between the firmware in use in the US.
 
Upvote 0

Rob

New Member
Messages
9
Points
3
I am now 100% convinced the IVMS-4500 app is at fault. I have a new main board, updated firmware and everything on the NVR functioning perfectly including smart events (e.g line crossings) being captured on the NVR. Unfortunately, it looks like the IVMS-4500 app for iphone hasn't been updated in 11 months - per the Apple app store. The reviews at the Apple store are overloaded with comments about alarm pushes no longer working (among other functionality issues). I have to speculate that Hikvision IVMS-4500 developer simply has not kept up with the Apple IOS updates.
Very disappointing and frustrating!
 
Last edited by a moderator:
Upvote 0

JB1970

Well-Known Member
Messages
869
Points
63
I am now 100% convinced the IVNMS-4500 app is at fault. I have a new main board, updated firmware and everything on the NVR functioning perfectly including smart events (e.g line crossings) being captured on the NVR. Unfortunately, it looks like the IVMS-4500 app for iphone hasn't been updated in 11 months - per the Apple app store. The reviews at the Apple store are overloaded with comments about alarm pushes no longer working (among other functionality issues). I have to speculate that Hikvision IVMS-4500 developer simply has not kept up with the Apple IOS updates.
Very disappointing and frustrating!
I only use Hik Connect at home at home now but will fire up iVMS, set up a couple of events and post back the results shortly....
 
Upvote 0

JB1970

Well-Known Member
Messages
869
Points
63
I only use Hik Connect at home at home now but will fire up iVMS, set up a couple of events and post back the results shortly....
Just checked and I can confirm push to iVMS-4500 is no longer working. I have had it working since the last update, so I can only assume that a change in one of the iOS updates has broken the functionality.

I've just checked on another system I installed and although it's a discontinued model, your E series NVR will support Hik Connect. Is there a reason that you don't want to use Hik Connect instead of iVMS-4500? It works so much better than iVMS-4500 especially with regard to events:
  • push notifications straight to the app even when closed (notification centre only in iVMS-4500 if closed)
  • thumbnail images of event trigger
  • filtering of events by date
  • event playback
  • one key arm/disarm of notifications
  • frequent updates
To be honest - the only downside to Hik Connect is that to receive the notifications, you need to make the connection in the app via Hik Connect registration. If you connect using IP address or domain name, live viewing and playback will work as normal but push notifications will not.
 
  • Like
Reactions: Rob
Upvote 0

Rob

New Member
Messages
9
Points
3
JB - I can't thank you enough for your replies! I have been tearing my hair out on this and you taking the time to check and confirm that the pushes are not working on IVMS-4500 is very kind of you and extraordinarily helpful (validates I wasn't something I had wrong).

The only reason I didn't use Hik-Connect is I thought by creating an account I would only be able to use the cloud based alerts, etc... From what you shared it does sound like using HIK-Connect via a local IP will not allow push alarms to work.

I am probably showing my ignorance here, but my worry was that using anything other than my local IP Domain would make my home network vulnerable. Am I off base on this?

Many Thanks again for your help!
 
Upvote 0

JB1970

Well-Known Member
Messages
869
Points
63
JB - I can't thank you enough for your replies! I have been tearing my hair out on this and you taking the time to check and confirm that the pushes are not working on IVMS-4500 is very kind of you and extraordinarily helpful (validates I wasn't something I had wrong).

The only reason I didn't use Hik-Connect is I thought by creating an account I would only be able to use the cloud based alerts, etc... From what you shared it does sound like using HIK-Connect via a local IP will not allow push alarms to work.

I am probably showing my ignorance here, but my worry was that using anything other than my local IP Domain would make my home network vulnerable. Am I off base on this?

Many Thanks again for your help!
No problem, I still have iVMS-4500 in use but I generally use it to quickly add sites temporarily while setting up and testing after installation.

Yes, in order for push notifications to work with the Hik Connect app, the connection to the system has to be via the Hik Connect registration. I'd rather it wasn't that way, as I'd prefer connection "directly" to either a static IP or my own domain name. I guess, unfortunately, it just has to be that way to support push notifications with the enhanced features.

There are always going to be security risks to some extent from having devices connected to the internet. Even with connection direct to your IP or domain that risk is exists. I suppose we have to weigh that minimal risk, against the functionality that a service provides - otherwise we wouldn't have any of our IoT devices (TVs, Smart Hubs etc).
 
  • Like
Reactions: Rob
Upvote 0

Rob

New Member
Messages
9
Points
3
...and just like that (July 22, 2021) the smart event line crossing push notifications are now working. Changed nothing on my end. There were no IVMS_4500 app updates for IoS, so what made it work? I have to assume somewhere (wherever the server is) there was a fix. While I am glad they are now working again, I would really like to know what the reason is for the issue - certainly was not on my end.
 
Last edited:
Upvote 0
Solution
Top