01304 827609 info@use-ip.co.uk Find us

Hik-Connect Alarm Notifications IVMS-4500

Rob

New Member
Messages
11
Points
3
I have a DS-7604NI-E1/4P and have been utilizing it over my local area network (IP Domain). No issues for a couple years - just recently my alarm notifications stopped coming through the IVMS-4500 app. The DVR is capturing the alarms and can produce an audible alarm, but nothing is coming to the iphone on the IVMS-4500 app. I have checked that alarm notifications are on, notifications are turned on phone, deleted and re-input the line crossing alarms (was sure to check off "notify surveillance center), rebooted the DVR, deleted and redownloaded IVMS-4500 and still nothing. I even tried rebooting my TP-link router. I am able to see the live cameras and recordings on the IVMS-4500, just no alarm notifications.

Any thoughts out there on what may be happening? I appreciate any help you can provide!
 
Solution
...and just like that (July 22, 2021) the smart event line crossing push notifications are now working. Changed nothing on my end. There were no IVMS_4500 app updates for IoS, so what made it work? I have to assume somewhere (wherever the server is) there was a fix. While I am glad they are now working again, I would really like to know what the reason is for the issue - certainly was not on my end.

Rob

New Member
Messages
11
Points
3
Update - I discovered all 4 of my PoE ports indicating PoE overload (message looks like it has been occurring for months) - pretty sure something inside the NVR is bad. Every port shows 3059.1W for a total of 12236.5W. Entire system had been working flawlessly for over a year. I don't think there was any sort of power surge since NVR is tied into a surge suppressor.
 
Upvote 0

Rob

New Member
Messages
11
Points
3
Update - received NVR back from Hikvision. There was a bad main board which was causing the poe overload - they replaced the board. Unfortunately, the line crossing alarm alerts still do not come through to the IVMS-4500 app. Very frustrating since I know I have them set up correctly - so remains a mystery to me what is causing this.

As an aside, I found it interesting the equipment came back with a firmware build that is not the most current and isn't even listed as on "older version" on the website (close but not exact on the build #) . I am afraid to update to the most current since I am wondering if they technician knows something about the firmware that may have contributed to the poe overload.

Any thoughts out there from anyone?
 
Upvote 0

JB1970

Well-Known Member
Messages
1,121
Points
83
Update - received NVR back from Hikvision. There was a bad main board which was causing the poe overload - they replaced the board. Unfortunately, the line crossing alarm alerts still do not come through to the IVMS-4500 app. Very frustrating since I know I have them set up correctly - so remains a mystery to me what is causing this.

As an aside, I found it interesting the equipment came back with a firmware build that is not the most current and isn't even listed as on "older version" on the website (close but not exact on the build #) . I am afraid to update to the most current since I am wondering if they technician knows something about the firmware that may have contributed to the poe overload.

Any thoughts out there from anyone?
For the alarms you may have to use the Hik Connect app. Unfortunately, unlike iVMS-4500, the NVR needs to be registered/connected with Hik Connect for the notifications to work (with iVMS-4500 where you could connect by IP/Domain and have them work). There was a user on the IPCam Talk forum the other day having similar issues with iVMS 4500 - he was no longer receiving notifications for hard wired NVR alarm inputs with no obvious reason why. Not sure whether this could be due to a change in the app or maybe even something in the phone operating system - iOS.

I wouldn't have any concerns about loading the latest firmware. What is the full model number of your NVR and what is the firmware version and build number they've put on it?
 
Upvote 0

Rob

New Member
Messages
11
Points
3
Thank you for your response.
My NVR is Hikvision DS-7604NI-E1/4P and firmware V3.4.96 build 171128 was loaded when it came back after they replaced the main board.
I am in the U.S. and the Hikvision website shows v3.4.96 build 181107 as the last best build for the NVR model - that's what it had on it when I sent it in for repair.
As mentioned, I am afraid to update to the most current since I am wondering if the technician knows something about the firmware that may have contributed to the poe overloads.
The lack of the alarm pushes is really disappointing - can see the cameras and playback video on the IVMS-4500 but not alarm push alerts.
Thanks again for thoughts on this.
 
Upvote 0

JB1970

Well-Known Member
Messages
1,121
Points
83
For that NVR the latest firmware in the European download portal is 3.4.98_171121 and in the UK portal it is 3.4.106_191009. Unfortunately I'm not sure whether there are differences between the firmware in use in the US.
 
Upvote 0

Rob

New Member
Messages
11
Points
3
I am now 100% convinced the IVMS-4500 app is at fault. I have a new main board, updated firmware and everything on the NVR functioning perfectly including smart events (e.g line crossings) being captured on the NVR. Unfortunately, it looks like the IVMS-4500 app for iphone hasn't been updated in 11 months - per the Apple app store. The reviews at the Apple store are overloaded with comments about alarm pushes no longer working (among other functionality issues). I have to speculate that Hikvision IVMS-4500 developer simply has not kept up with the Apple IOS updates.
Very disappointing and frustrating!
 
Last edited by a moderator:
Upvote 0

JB1970

Well-Known Member
Messages
1,121
Points
83
I am now 100% convinced the IVNMS-4500 app is at fault. I have a new main board, updated firmware and everything on the NVR functioning perfectly including smart events (e.g line crossings) being captured on the NVR. Unfortunately, it looks like the IVMS-4500 app for iphone hasn't been updated in 11 months - per the Apple app store. The reviews at the Apple store are overloaded with comments about alarm pushes no longer working (among other functionality issues). I have to speculate that Hikvision IVMS-4500 developer simply has not kept up with the Apple IOS updates.
Very disappointing and frustrating!
I only use Hik Connect at home at home now but will fire up iVMS, set up a couple of events and post back the results shortly....
 
Upvote 0

JB1970

Well-Known Member
Messages
1,121
Points
83
I only use Hik Connect at home at home now but will fire up iVMS, set up a couple of events and post back the results shortly....
Just checked and I can confirm push to iVMS-4500 is no longer working. I have had it working since the last update, so I can only assume that a change in one of the iOS updates has broken the functionality.

I've just checked on another system I installed and although it's a discontinued model, your E series NVR will support Hik Connect. Is there a reason that you don't want to use Hik Connect instead of iVMS-4500? It works so much better than iVMS-4500 especially with regard to events:
  • push notifications straight to the app even when closed (notification centre only in iVMS-4500 if closed)
  • thumbnail images of event trigger
  • filtering of events by date
  • event playback
  • one key arm/disarm of notifications
  • frequent updates
To be honest - the only downside to Hik Connect is that to receive the notifications, you need to make the connection in the app via Hik Connect registration. If you connect using IP address or domain name, live viewing and playback will work as normal but push notifications will not.
 
  • Like
Reactions: Rob
Upvote 0

Rob

New Member
Messages
11
Points
3
JB - I can't thank you enough for your replies! I have been tearing my hair out on this and you taking the time to check and confirm that the pushes are not working on IVMS-4500 is very kind of you and extraordinarily helpful (validates I wasn't something I had wrong).

The only reason I didn't use Hik-Connect is I thought by creating an account I would only be able to use the cloud based alerts, etc... From what you shared it does sound like using HIK-Connect via a local IP will not allow push alarms to work.

I am probably showing my ignorance here, but my worry was that using anything other than my local IP Domain would make my home network vulnerable. Am I off base on this?

Many Thanks again for your help!
 
Upvote 0

JB1970

Well-Known Member
Messages
1,121
Points
83
JB - I can't thank you enough for your replies! I have been tearing my hair out on this and you taking the time to check and confirm that the pushes are not working on IVMS-4500 is very kind of you and extraordinarily helpful (validates I wasn't something I had wrong).

The only reason I didn't use Hik-Connect is I thought by creating an account I would only be able to use the cloud based alerts, etc... From what you shared it does sound like using HIK-Connect via a local IP will not allow push alarms to work.

I am probably showing my ignorance here, but my worry was that using anything other than my local IP Domain would make my home network vulnerable. Am I off base on this?

Many Thanks again for your help!
No problem, I still have iVMS-4500 in use but I generally use it to quickly add sites temporarily while setting up and testing after installation.

Yes, in order for push notifications to work with the Hik Connect app, the connection to the system has to be via the Hik Connect registration. I'd rather it wasn't that way, as I'd prefer connection "directly" to either a static IP or my own domain name. I guess, unfortunately, it just has to be that way to support push notifications with the enhanced features.

There are always going to be security risks to some extent from having devices connected to the internet. Even with connection direct to your IP or domain that risk is exists. I suppose we have to weigh that minimal risk, against the functionality that a service provides - otherwise we wouldn't have any of our IoT devices (TVs, Smart Hubs etc).
 
  • Like
Reactions: Rob
Upvote 0

Rob

New Member
Messages
11
Points
3
...and just like that (July 22, 2021) the smart event line crossing push notifications are now working. Changed nothing on my end. There were no IVMS_4500 app updates for IoS, so what made it work? I have to assume somewhere (wherever the server is) there was a fix. While I am glad they are now working again, I would really like to know what the reason is for the issue - certainly was not on my end.
 
Last edited:
Upvote 0
Solution

Rob

New Member
Messages
11
Points
3
...here we go again - (1st week of September 2021) with no changes on my end (just like prior stoppages) push notifications are no longer coming through. This is absolutely infuriating!
 
Upvote 0

Rob

New Member
Messages
11
Points
3
Simply want to report that mysteriously push notifications have now resumed (I did absolutely nothing on my end). I really would love to know what causes this (server?) and why there isn't some form of a place where customers can see reports of an "outage" or whatever the reason is for these mysterious "stops" in push notifications for IVMS-4500. Thanks!
 
Upvote 0

Old cam guy

New Member
Messages
4
Points
1
New here and found the forum when looking for info on this issue.
Just though I'd let you know what I have seen with this.
I monitor about 30 systems for clients using Hikvision NVR's and DVR's . They have both IP and TVI
cameras. Some systems are branded, some are OEM and range in age from newly installed to about
7 years old.
The line crossing and alarm push notifications had worked very well for everyone until the first time we
had this issue in 2019.
When the notifications stop, everyone I monitor had the same problem " if " they had an iPhone and were
running ivms-4500 or nvms7000. As a test in the early stage of seeing this we had tried changing the region setting
in the app and it worked in some cases.(thinking it was the US server) We also tried using NVMS7000 and it
would work in some cases when the ivms-4500 did not. Nothing consistent other than iPhone.
The recent times when it has stopped working, three times this year now, including at about 6:30pm today
nether app works.
Every time it has happened, when viewing the systems on a PC or laptop running ivms-4200 or using a
phone with ivms-4500 or nvms7000 other than an iPhone it works fine.
Several months ago when it had stopped working, there was an update for the iPhone iOS and after the
install, notifications were turned off for all the systems within the app. When they were turned back on
everything worked again but it did not last. The fact that the update turned off notifications tells me
something in that update was related to notifications.
This tells me the problem is definitely within the iOS from apple and/or the apps compatibility. Unless they work
something out the feature for notifications is very unreliable.

I found it interesting that the first thing Hikvision wanted was the system serial number.
When 30 systems stop working at the same time and the only two things they have in common is the
app and the phone type, it’s not the DVR/NVR. They never would admit there was any kind of problem.
Very frustrating having to try and explain this to all my clients with no support from the manufacture.

Just my 2cents
 
Upvote 0

SimpJ

New Member
Messages
2
Points
1
Same exact problem with my HIK DVR 7208HGHI-SH. Worked fine since installing in 2016, but recently I don't regularly get alarm push notifications on my iPhone 8 using the iVMS-4500 app. I can see live views, events are being recorded and I can playback events. Some days it's working then for no reason it doesn't. When it's not working I do get an interesting message in the app that has not been mention above. From the iVMS-4500 app menu select "Alarm" > "Set Alarm Notification" > toggle on/off. When the alarm pushes are working this toggle works fine. When pushes are not working I get the message "Failed to log out of the push server." when I select the toggle on/off. I have no idea what this means, but maybe some of you might? Hikvision support claims they've never heard of this.
 
Upvote 0

Old cam guy

New Member
Messages
4
Points
1
I have seen a similar message “failed to connect to server” and I don’t doubt that Hikvision said they have never heard of it. I’m not sure why they are so bad about there support but it disappointing for such a large company.

I don’t have a MAC, just a few laptops and a main PC. They all run the ivms-4200 and notification still work as they do on non-iPhones . If any of you have the time try loading ivms-4200 on your computer and see if it gets notifications when your phone stops. They do have a version for MAC’s and I have a client using it but I have not had a chance to check with him to see if he receives notification on it when his phone stops.

Hopefully Hikvision does something soon with this. Many of my clients depend on this feature for security. It’s like having an alarm system that only works part of the time, why have it at all.
 
Upvote 0

Old cam guy

New Member
Messages
4
Points
1
As of 11:45pm last night all the systems went back to pushing notifications to iPhones. No changes on my end , they just started working again .
 
Upvote 0

SimpJ

New Member
Messages
2
Points
1
After no changes on my end, push notifications began working again about 10 days ago on my iPhone 8, but not my wife's iPhone 6s. She got a new iPhone 11 a few days back and the push notifications worked from the start and no more issues to date. All phones had the latest OS updates, but is it possible her older 6s could have been causing issues since my phone was linked to hers?
 
Upvote 0
Top