01304 827609 info@use-ip.co.uk Find us

ANPR Bug with HikVision NVR

lau110

Member
Messages
40
Points
8
Hi guys,

I thought I'd post on here about a rather strange problem we've encountered with our DS-7216HUHI-K2 DVR. We use a DS-2CD4A26FWD-IZHS/P (running firmware 5.4.7) and have noticed on any NVR firmware 4.20.000 and up, the NVR will not function with ANPR and displays Chinese characters under the "province/state abbreviation" menu (shown in screenshot below) or in some cases, nothing at all, just the "number of lanes" option but still will not write any plates even though the ANPR camera itself is reading plates by itself just fine. I've emailed HikVision to report the issue but am wondering if anyone else has noticed this with ANPR cameras in combination with a DVR/NVR running 4.20.000 and up? Any input would be much appreciated.

Thanks!
 

Nigels89

Member
Messages
35
Points
8
Hello

I must say I have never seen this before, what I have seen before under "province/state abbreviation" is Chineses sates in English displayed, have you tried setting it up through the NVR/DVR direct instead of going through the web browser?

Also there is a different firmware for the 4 line ANPR camera that not long been released 5.4.5 build191012

 

lau110

Member
Messages
40
Points
8
With 4.20.100 I seemed to have the ANPR camera working via setup from the NVR briefly however all of a sudden again plates are not being written to the NVR even though they are reading as they should in the ANPR camera. Notably in this firmware version I'm not seeing anywhere to adjust ANPR settings directly on the NVR itself, just through the web browser. On the HikVision UK portal there seem to be 2 listings of "ANPR" firmware. HIKVISION UK PORTAL and HIKVISION UK PORTAL. Are either of these incorrect for this camera or could this be causing it?
 

Nigels89

Member
Messages
35
Points
8
I'm not very familiar with you DVR, the only experience I have is with I series. To get to the ANPR Settings go to Systems -> Events -> Smart Events -> Click on your ANPR Cam in list.

Make sure that save VCA Picture is checked marked as it will not save picture to the NVR.
IMG_4148.jpeg

Both of the firmware are correct for you camera.
 

lau110

Member
Messages
40
Points
8
Managed to find the ANPR options thanks to your picture, completely didn't occur to me that it was under smart events in the DVR interface, I was looking for some sort of VCA menu the whole time. The setup shown in your picture looks basically identical to our options with VCA picture turned on and the settings seem to correctly duplicate as they were in the browser. After some more digging about today it seems as though the firmware has different characteristics for LPR detection inside the DVR. It is now recording most of the same plates as the ANPR camera itself however there are instances where plates recorded by the camera are missing from the DVR detection, sometimes a number have been missed. Also it appears that searching by plate number is not working from the DVR. I am definitely experiencing the issue regardless of camera firmware that 4.21.100 on the DVR is completely broken and Chinese characters are showing in the provinces area of the vehicle detection menu. Unfortunately when I contacted HikVision's UK support my email was forwarded to the most unhelpful rep who chose to explain to me the entire company distribution model rather than acknowledging a potential firmware issue and escalating it. A few years ago I emailed HikVision directly with an iOS app issue and they were more than happy to help, it is disappointing to see this kind of approach taken by them as last time I checked distributors weren't the ones who made the firmware. Perhaps somebody is able to report the issue to HikVision from Use-IP?
 
Top