01304 827609 info@use-ip.co.uk Find us

Hik-Connect Hik Connect - App Crash iOS

JB1970

Well-Known Member
Messages
650
Points
63
So my Hik-Connect app (version 4.10) has failed completely this morning. Opened the app, a brief flash of the splash screen then off. I've closed all apps, rebooted the phone but that made no difference.

When I checked the App Store there was an update for Hik Connect (version 4.11) so I've loaded this to update it, but the result is the same and the app won't open. This is purely an issue with the app/phone and I can still connect to the system and view/configure using Hik-ProConnect.

I noticed a few days ago that although my phone has been working fine and holding charge - in the iPhone X - Settings > Battery. Battery Health is showing "Service" and under Peak Performance Capability it's detailing that the "battery health is significantly degraded and peak performance may be impacted". Hik-Connect has been working normally after this until this morning but I'm wondering if Apple nerfing my phone is the cause...or am I looking for an excuse to get a shiny new iPhone 12 Pro?
 

JB1970

Well-Known Member
Messages
650
Points
63
Strange. The failure happened while using an app version that had been working for sometime before updating to the latest version. I had to uninstall and reinstall the app - something I've never needed to do before but it's working normally again now. Guess the new iPhone will have to wait...
 

TEE

New Member
Messages
1
Points
1
Today 11/3/2021 app crashed on 3 different models of device, reinstalled latest app version but still the same??
 

Simon Jones

New Member
Messages
23
Points
1
I'm now getting this exact same problem on my iPhone 11 since the app updated automatically recently!!

Did you ever find a way to sort it if you don't mind me asking?
 

Ross Ff

New Member
Messages
1
Points
1
I'm now getting this exact same problem on my iPhone 11 since the app updated automatically recently!!

Did you ever find a way to sort it if you don't mind me asking?
I’m also having the same issue ! Due to the app update, I havnt found a solution yet tried everything I can think off
 
Top