• Hi Guest, Please subscribe to our YouTube channel for fresh new videos each week.

Hikvision Buffer Overflow Vulnerability

Phil

Administrator
Staff member
Messages
2,254
Likes
194
Points
63
Thread starter #1
Hikvision have declared a possible vulnerability and released a fix for it.

As is normal, the best advice is to please make sure you keep your devices updated to the latest available firmware version.

More details:

A buffer overflow vulnerability in the web server of some Hikvision IP Cameras allows an attacker to send a specially crafted message to affected devices. Due to the insufficient input validation, a successful exploit can corrupt memory and lead to arbitrary code execution or crash the process. Read more...
 
Messages
7
Likes
2
Points
3
#2
Thanks Phil. One of my cameras was on the affected list, but the Hikvision U.S. website still showed the impacted/affected firmware as the 'newest' out there. I finally found the newest version by doing a google search of the exact IP camera model and accidentally came across it on the Europe Hikvision website when someone linked it on another website because they couldn't reset their password. By viewing the firmware folder of the different versions on the Europe Hikvision website, I found the newest version and flashed the firmware. All good to go now :)
 
Last edited:
Top