• Hi Guest, Please subscribe to our YouTube channel for fresh new videos each week.

Hikvision camera losing its main stream settings (after access via the Hik-Connect mobile App)

adatay92

New Member
Messages
1
Points
1
Thread starter #1
Hi,

I've got a DS-2CD2142FWD-I on my home network, it's the only camera I have.
  • Not using a DVR, camera isn't set to record
  • Gigabit network, using PoE
  • Using Hik-Connect for DDNS and the Hik-Connect app on the iPhone
The main stream seems to randomly switch from 2688*1520 down to 1280*720P and a decent framerate and bitrate down to 10fps, and 512Kpbs.

If I change it to what I want it seems to "save" OK and live view looks great. Then a day or two later I notice that the live view quality is poor and when I check the settings it has reverted again!

I have no idea what is causing it. Does anyone have any ideas?
 

laciii

New Member
Messages
1
Points
1
#2
Hi! I'm having the exact same problem and I don't know why... Have you managed to repair it?

Thanks!
 

BjornW

New Member
Messages
5
Points
3
#4
Hi, I have exactly the same problem. Can someone confirm that upgrade to 5.5.0 firmware solves this? Seems a bit strange that such a serious fault was not corrected until now.
 

BjornW

New Member
Messages
5
Points
3
#6
Hi,
Ok, thanks, I have a 2CD-2142FWD so I'll go for this one:
Baseline Firmware_IPC_ML_V5.5.0_170725(2XX2(F)WD, 2X52(F), 64X4, XM66X2)
Cannot find any information in the release notes that the problem with lost settings is solved but I guess I will notice after upgrade :) //Björn
 

BjornW

New Member
Messages
5
Points
3
#8
Hi again.
So I upgraded to 5.5.0 and I think the problem is still there, seems that low quality is set for some reason. I set 1920x1080 and save it. Then, after a few days it is back at lower resolution. One thing I noticed after upgrade (might have been there before also) is that the video is bad, really bad. Except from noisy picture in general it becomes a disaster when objects move. The regions close to the objects are very distorted. I cannot understand how this can be, must be a major software bug. I tried resetting everything to default including restart, still the same problem. This would need to be reported to Hikvision, since it more or less makes the camera unusable. Have I done something wrong to trigger this behaviour? I have attached to images and marked the worse places with red.

When I bought my camera DS-2CD2142FWD this summer it first worked quite good and I was satisfied with it. Then things have gotten worse and worse.

//Björn
 

Attachments

Last edited:

Phil

Administrator
Staff member
Messages
2,531
Points
63
#9
How do your video stream settings compare with the below please?

Are you using an NVR and/or IVMS-4200 software with the cameras?
(can conflict / overwrite settings)

4MP setup 4-12-17.png
 

BjornW

New Member
Messages
5
Points
3
#10
Hi,
Sorry for late answer. My settings are similar to yours, please see attached pictures. I set high resolution and max bit rate also high, according to picture named "Before.png". In this state the video from the camera is very good quality. Then, after checking live view or anything, after like 5 minutes or so the settings have been reset to 512 kbps and low resolution ans it looks like crap. Also frame rate has been set to 10 fps. I do not use NVR or iVMS app. I do use an EZVIZ app (H&L Cam) via Hik-Connect but did not change any settings in it during this test so it should not affect. I have my camera connected via LAN cable about 7-8 meters to my router, bandwidth should not be the problem. Is there any possibility to activate some debug or trace log in order to report to HikVision? Then it would be possible to understand why the software thinks the settings shall be reset.

//Björn
 

Attachments

Phil

Administrator
Staff member
Messages
2,531
Points
63
#11
Hi Björn,
Hmm something is obviously resetting your camera's settings.
I'm not seeing/hearing reports of similar from hundreds of other customers who have updated cameras.
I guess Step 1 would be to rule out the App you are using - maybe uninstall/ don't use that for a few days; keep checking your camera from your PC browser and see if it still resets the settings.

The cameras do have a log feature. You need to install a microSD card to use it:
(screenshot from a different model of camera to yours)

HikVision camera log 11-12-17.png
 

BjornW

New Member
Messages
5
Points
3
#12
Hi,
I executed the logging according to your description above. I also isolated what triggers the "reset" - it IS caused by the mobile app. This is the way to reproduce it:
-Set for example 1920x1080, 18 fps and bitrate 16384kbps.
-Stream live view in mobile app with setting quality=High-Def. This works, camera keeps it's settings.
-Change (in mobile app) to quality=Basic and stream live view. Still works, camera keeps the settings.
-Now switch back (in mobile app) to High-Def. Now the camera resets to 1280x720, 10 fps and 512kbps
So it seems that the setting of lower/higher resolution in the app causes the reset and then it never goes back to the higher settings.
In the log taken I see a message (translated): Remote function: Changed settings.
I guess that is caused by the resolution change in my app. You know if there is a way to block remote settings to the camera? One way is to always view in app using Hi-Def but we are a couple of users so thats not a perfect solution.

Best regards Björn
 

Phil

Administrator
Staff member
Messages
2,531
Points
63
#13
Hi Björn, Well Done for working this out and sharing it. I've not come across it before. We can only hope it's a glitch that will be resolved in the next update of the firmware or the App.
 

Osman

New Member
Messages
2
Points
1
#14
He hello, Here Bart from they other side of the north sea (holland). So excuse me for my bad english.

I finally found someone with exactly the same problem!!!!

Does anyone already have a solution for this?

I am already in conversation with hikvision europa about this problem but this is only in the initial phase.

Hope to hear from you.

Best regards Bart
 

alexf40

New Member
Messages
25
Points
3
#15
I've got exactly the same problem since upgrading my cameras to 5.4.5, I tried disabling Hik-connect, and the NVR settings. I do use AngelCam for live viewing. Wonder if that is changing the defaults. Will take a look.

My cameras are DS-2CD2332-I and I don't think I can enable logging. My issue is that when I change the resolution/framerate etc it saves correctly, but even on just changing tab and returning it resets to the lower resolution.
 
Last edited:

alexf40

New Member
Messages
25
Points
3
#16
Hopefully mine is now fixed. Restarted the NVR and changed the settings in there and so far so good.

If this is the issue it must have been due to the firmware upgrade on the NVR.
 

Osman

New Member
Messages
2
Points
1
#17
I’m not using a nvr, just a internal sd card.

I upgraded the latest firmware in to the camera and still have the
problem.

I let you know when i have a solution from Hikvision.
 

rompik

New Member
Messages
10
Points
3
#18
It seems Bjorn spot on. I have exactly the same problem with both types of cameras I have: DS-2CD2555FWD-IWS and DS-2CD2455FWD-IW on latest firmware.
I have no NVR, just NAS drive to record video. Everything works fine until I run Hik-Connect app (latest ver) on my mobile. After changing quality in mobile app (eg. to HD) all video settings are set to lowest (1280x720, 10fps, 512kbps, etc).
 

HZn45%#Vu7

New Member
Messages
2
Points
3
#19
I registered just to comment on this thread as I am having the same issues. While I have no solution, I can offer the additional observations in the event they are relevant.
I have a 2cd2132 and a 2cd2142. Both setup using ivms-4200 windows client. I set the image resolution settings to 1080p and 4mp respectively. I added both cameras to the hik-connect. When using the hik-connect app and adjusting the incoming signal resolution using the app (basic, SD, HD), it actually changes the settings in the camera itself. I was unaware that setting up with hik-connect and utilizing the encryption verification code that operator level abilities were available with the app.
Additionally, I made a 2nd hik-connect profile and had the primary Hik-Connect user "share" the cameras with the 2nd account - thinking that a shared camera would not have the ability to change settings with the camera itself. To no avail, using either Hik-Connect profile (device or shared device) changing the settings on the app alters the camera stream back to this basic simple setting as described above.

I did however, use an old version of the app (IVMS4200) and the setting change did NOT commit to the camera when making a change with the app. But, the old app kinda sucks.

Any other suggestions/thoughts?
 

Phil

Administrator
Staff member
Messages
2,531
Points
63
#20
@HZn45%#Vu7 Thanks for the extra info you have added.
It does seem to be a problem that is affecting a lot of people, although not all.
Various of us have reported this to Hikvision Tech Support, but as yet they don't seem to have acknowledged it / fixed it. Nor, to the best of my knowledge provided any suggestions that prevent this happening.
This thread dates back to May 2017.

Is their any notable commonality between users experiencing this?
Are you all for instance using the Android or the IOS App?

iTunes web page for the IOS version of the Hik-Connect App
Google Play Store web page for the Android version of the Hik-Connect App

The Hik-Connect App is updated fairly frequently.
I cannot find the changelog for the Android version at the Google Play store, I note that the latest Android version currently is 3.4.3.0517 - updated 24th May.

Below is the IOS version changelog, you can see that there have been many updates:

Version History
  • 3.4.3
    2 May 2018
    1.Supports the intercom door station with two locks.
    2.Supports more countries and regions.
    3.Increased volume of two-way audio.
    4.Optimized ringtone of intercom door station and doorbell.
    5.Bug fixed
  • 3.4.2
    19 Apr 2018
    1. Optimized the Home page and the Live View page.
    2. Supports sharing/deleting the captured pictures and recorded video files in batch.
    3. Supports clearing all alarm messages.
    4. Bug fixed.
  • 3.4.1
    4 Apr 2018
    1. Optimized the Home page and the Live View page.
    2. Supports sharing/deleting the captured pictures and recorded video files in batch.
    3. Supports clearing all alarm messages.
    4. Bug fixed.
  • 3.4.0
    2 Apr 2018
    1. Optimized the Home page and the Live View page.
    2. Supports sharing/deleting the captured pictures and recorded video files in batch.
    3. Supports clearing all alarm messages.
    4. Bug fixed.
  • 3.3.3
    11 Feb 2018
    Bug fixed.
  • 3.3.2
    2 Feb 2018
    1.Upgrade online devices added by IP/Domain.
    2.Adapt to iPhone X.
    3.Add channel-zero enabling/disabling switch. By default, it is disabled.
    4.Support sharing saved photo and video.
    5.Bug fixed.
  • 3.3.1
    24 Jan 2018
    1.Upgrade online devices added by IP/Domain.
    2.Adapt to iPhone X.
    3.Add channel-zero enabling/disabling switch. By default, it is disabled.
    4.Support sharing saved photo and video.
    5.Bug fixed.
  • 3.3.0
    19 Dec 2017
    1.Add access control related functions.
    2.Optimize feedback function: Support hiding feedback panel.
  • 3.2.0
    16 Nov 2017
    1.Optimize live view performance in multiple windows mode and make live view more fluent.
    2.Auto detect the device type and enter the corresponding adding page.
    3.Switch between thumbnail and list mode on home page. Slide device to left in list mode to share and set.
    4.Preview live view in small window on home page.
    5.Optimize UI design of live view page. Slide to view all live videos.
    6.Share by device or channel. Receive sharing notifications.
    7.Optimize feedback function on the Message page.
  • 3.1.0
    7 Sep 2017
    1、Optimize home page: Support switching between the screenshot mode and the list mode.
    2、Optimize sharing permissions: Support sharing permissions of capturing, recording, zooming, and editing preset.
    3、Optimize live view in landscape mode: Support changing video qualities.
    4、Optimize playback: Support selecting time before playing videos.
  • 3.0.0
    13 Jul 2017
    Optimize Home page; Support selecting multiple cameras for live view.
    Optimize live view module; Support slide to switch the camera in live view module.
    Optimize playback module; Support 4 window divisions in playback module.
    Support video sharing and managing sharing settings.
    Support adding cameras to Favorites.
    Support adding preset in PTZ function.
    Support setting PTZ speed.
    Optimize streaming speed in live view module.
  • 2.1.0
    27 Apr 2017
    1) Optimize live view interface: The Hik-Connect module and Device module use the same live view interface.
    2) Add help document.
    3) Support PTZ control in full screen mode.
    4) Support zoom function.
    5) Add 19 language
    6) Fix some bug.
    7) Optimize the notification of alarm information.
  • 2.0.2
    18 Mar 2017
    1) Sharing of Hik-Connect domain name supported.
    2) Push services improved.
    3) Some bugs fixed
  • 2.0.0
    9 Jan 2017
    1) Supports adding the device without login.
    2) Supports adding the device via IP/Domain.
    3) Supports adding the device via Hik-Connect Domain.
There are more/earlier updates, but these cover the duration of this thread.

I haven't re-visited these App download pages for some time, there are a lot of low score reviews, resulting in a rating of 2.8 in the iTunes store and 3.9 in the Android Google Play store.

The IOS store offers the below contact email for support:
support@hikvision.com
 
Top