01304 827609 info@use-ip.co.uk Find us

HikVision-Connect - newbie can't get camera online

Doug Williams

New Member
Messages
5
Points
1
Hi everyone,
Sorry for the long post - just trying to be complete!

I have one Hikvision bullet camera, DS-2cd2022WD-1 4mm camera.
I have updated to the following firmware: V5.4.5 build 170124
I can't get my cameras as registering to be 'online' though I can see live streams on both LAN and the wider Internet...

I am trying to set up a goat cam so we can watch our pregnant pygmy goat. At the moment I am just concerning myself with getting a live feed working properly.
I have one camera added to the network and I can see the camera feed on the LAN and have done the port forwarding thing so I can see the image via apps etc on the Internet at large.

I am on a BT Home Hub and my IP address is not fixed. I understood that the new HikVision-Connect service superseded/subsumed the old HiDDNS service to overcome this.

I want to register my camera on the HikVision-Connect service but find myself incapable of adding it. My camera, despite me being able to see the images on the wide internet, reports itself as being offline.
>Network>Advanced settings>Platform Access

Screen Shot 2017-05-09 at 17.44.16.png

In getting to this stage I have assumed that it is me that defines the verification code. Is that a mistake? Should I have taken the verification code from the back of the camera?

I spoke to HikVision who I persuaded to speak briefly to me even though, as one who purchased through Amazon, I am not entitled to their help (I didn't know that!). He suggested I need to change the DNS server addresses. I have a default set of 8.8.8.8 Google's DNS server. I have set no secondary DNS server. I did try changing to BT ones (As per my router) but no joy. I rebooted and lost those settings so am sticking with the 8.8.8.8 option.

Screen Shot 2017-05-09 at 17.44.35.png


In attempting to register on the Hik-Vision Connect site I type in the 9 digit serial number. It reports "The device is offline. No search result is found".
Screen Shot 2017-05-09 at 17.58.07.png


I suspect there is some obvious step (Perhaps several) I am overlooking. What confuses me is that whilst i can see the live feed of the camera using a direct IP address, the camera reports itself as being offline. Obviously I am misunderstanding something. Any help would be much appreciated. (We want to proceed from this, assuming we can overcome this hurdle, to event recording in order to capture the birth off the goats and to embedding the feed on a web site.)

Thanks in advance,

Doug
 

RBW

Member
Messages
73
Points
8
I'd set the 1st DNS address the same as your router/gateway address 192.168.1.1

2nd DNS as the google 8.8.8.8 address.

It may do the trick ;-)
 

Doug Williams

New Member
Messages
5
Points
1
Thanks, I have done that and pressed save. Pressing 'save' does not see to be enough...
Its still says offline here: Network>Advanced Settings>Platform window: Register Status
Should I reboot?

I am happy to reboot but have noted that every time I have tried it previously, I get a spinning wheel of death (I use a mac) and the process never seems to complete and restore. To be fair if I access the camera again it's there but it doesn't seem to remember any of the setting changes so that doesn't get me anywhere.
 

RBW

Member
Messages
73
Points
8
Is the RJ45 a home made cable?

Can you ping the camera from your pc?
 

Doug Williams

New Member
Messages
5
Points
1
RBW - I'm all sorted now. (Sorry I thought I had posted my thanks - could have sworn I did - perhaps I faoiled to press send...)
I followed your advice that the primary DNS server should be the IP address (local IP address) of my router. Once I had that in place my camera declared itself on-line and I could use the Hik-Vision service. So the advice from the HikVision guy (and you) was right. It's just that my router does not have the local IP address that he thought it would have. (mine ends 254 I think). I guess it may change from router to router; I looked mine up and was away...
 
Top