• Hi Guest, Please subscribe to our YouTube channel for fresh new videos each week.

Hikvision "Device is Offline"

FieldD88

New Member
Messages
4
Points
1
Thread starter #1
Morning all!

I am using Hikvision DVR with 8 Dome cameras, i can view all the cameras on the desktop client of IVMS but on my phone it states "Device is Offline" any ideas how i can fix?

The IP addresses match on both bits of software.

I have tried on both Android and IOS.

My DVR model is DS-7208HWHI-K1
 

Phil

Administrator
Staff member
Messages
2,967
Points
83
#4
Are you seeing the problem when using the Hik-Connect App on your phone(s)?

If so, what do you see when you visit the Hik-Connect portal on the web ( www.hik-connect.com ) with a browser and login with the same credentials?
 

FieldD88

New Member
Messages
4
Points
1
Thread starter #5
Are you seeing the problem when using the Hik-Connect App on your phone(s)?

If so, what do you see when you visit the Hik-Connect portal on the web ( www.hik-connect.com ) with a browser and login with the same credentials?
When i log into Hik-Connect on PC and try to add my DVR using the serial number it says it cannot find it.

However - i am using IVMS-4200 on PC (Latest version) and can view my cameras absolutely fine. They record etc. but when i try and view them with same IP Addresses etc on IVMS-4500 on my Android or IOS phone it states "Camera Offline"
 

Phil

Administrator
Staff member
Messages
2,967
Points
83
#6
It will be one of the issues that are listed in that Post that I linked you to.

Use the Hik-Connect App on your phone.

Your DVR needs to be able to 'phone home' to Hik-Connect's portal.
Until it is able to do so it will show as offline when you check the portal.

Check the items on that linked list.

The most likely causes are that you:
  • Have not enabled Platform Access.
  • Have not got your Network Settings configured correctly.
    • You need the correct IPv4 gateway address for your router entered in Network Settings.
    • AND, you must enter DNS settings.
 

FieldD88

New Member
Messages
4
Points
1
Thread starter #7
It will be one of the issues that are listed in that Post that I linked you to.

Use the Hik-Connect App on your phone.

Your DVR needs to be able to 'phone home' to Hik-Connect's portal.
Until it is able to do so it will show as offline when you check the portal.

Check the items on that linked list.

The most likely causes are that you:
  • Have not enabled Platform Access.
  • Have not got your Network Settings configured correctly.
    • You need the correct IPv4 gateway address for your router entered in Network Settings.
    • AND, you must enter DNS settings.
Still no joy!

Appreciate your help
 

Phil

Administrator
Staff member
Messages
2,967
Points
83
#8
Can you upload a screenshot of your Network Settings please?
 

fullboogie

Active Member
Messages
230
Points
28
#9
Hey, I found a solution to this problem. When in Config, Advanced, Platform Access and you're entering the server address, the default on my system was incorrect. For me, it needed to be "litedev.us.hik-connect.com" rather than what was listed which was "dev.hik-connect.com". Also, even if you have the correct server address listed, the "custom" box to the right cannot be ticked. If it is, even with the correct address, it will still say "offline." Untick that box and hit save and it'll work.
 

fullboogie

Active Member
Messages
230
Points
28
#10
I take it back. This POS HikConnect app is the worst thing I've ever used in my life. Deleted with prejudice and going back to 4500.
 

StewartM

Active Member
Messages
429
Points
28
#11
If you haven't thrown in the towel just yet, try the following.
First check your network settings:
2220

Next, setup Platform Access. There are many server addresses, 'litedev.us.hik-connect.com' is fine. Don't worry if the Register Status says offline, we will get to that.
2221

Probably the biggest issue is with adding the device to the Hik-Connect portal. If it's not added, you won't see it as online.
Log into Hik-Connect on your PC and try to add your DVR using 9 digits from the serial number toward the end. A fictitious example of a serial number would be: DS-7616NI-I2 / 16P1620181216CCRRC00633721WCVU - use the 9 digits in bold that correspond to your serial number. It normally starts with a C and ends with a number. You should fine this 9 digit number printed on the side of the box your DVR came in. Once the Hik-Connect portal finds your device, add it and the Register Status on your DVR will report online (may take a reboot).

Let me know if you make any progress.
 

fullboogie

Active Member
Messages
230
Points
28
#12
Stewart, I got it added and confirmed it was on the internet by ping and telnet. Then set up the app and could see my cams. I spent hours yesterday trying to get event notifications and it simply does not work. I know about ticking "notify surveillance center" and all that. I don't have 20 hours to devote to getting this POS working properly.
 

StewartM

Active Member
Messages
429
Points
28
#13
A few things that need to be enabled that are not obvious. Notify Surveillance Center enabled on both NVR and the cameras is one of them. Let's say you want to setup Line Crossing alerts to be sent to your phone.

On the camera, under Configuration>Smart Event>Line Crossing>Linkage Method make sure Notify Surveillance Center is ticked.
2224


On the NVR: Configuration>Smart Event>Line Crossing>Linkage Method make sure Notify Surveillance Center is ticked.
2225


On your phone (I only have Android to post captures from). Open the Hik-Connect app and slide your finger from right to left toward the edge of the screen. This uncovers the NVR settings.

2226


Click the cog.
2227


Make sure Alarm notification is enabled.
2228


2230


Log out of the app when done and back in. Now test the alerts. Keep us posted.
 

Kushi

New Member
Messages
1
Points
1
#14
Hi. I am having the same issue. Platform acces shows online but the app says camera is offline. Also in NAT settings I don't see the external ip addresses for the three ports? Can somebody please help me urgently ?thanks a lot in advance.
 

Thegovernor

New Member
Messages
4
Points
1
#15
Interesting, I have the DS-7604 been working fine since the 25th Feb when I bought it, now can't access it remotely via Hik-Connect. All works perfectly inside my LAN, no network changes, everything else is working fine, just can't access it via the app.

When I log in via the Hik portal it shows it as offline, although on the NVR itself it says it's online... maybe it's a wider problem is there's a few of us suddenly unable to connect?
 

Tw27

New Member
Messages
2
Points
1
#16
Hi,

I am having very similar issues with the same model have you managed to work out a solution yet?

Thanks in advance
 

suzanneocallaghan

New Member
Messages
18
Points
3
#17
i am so frustrated, i have tried every possible solution here. My device is offline for nearly 5 weeks. It dropped intermittently in the past but always came back on. Now it hasnt. I even changed my router in case that was the problem but no joy. My installer wont provide me with any back up service. If all the settings were correct one day and the device went offline the next, then there must be another problem than incorrect settings?
 

Phil

Administrator
Staff member
Messages
2,967
Points
83
#18
OK, there is obviously something going on here.
However, we are not receiving calls from our customers on this topic.

I am happy to try and help.
But it would be foolish to try to diagnose and resolve this with many people at once.
For every question I ask, or action I suggest, I'd receive multiple echoing responses.

So, @suzanneocallaghan please start a new thread in this Hikvision category.
Give us your problem and info, and we will see if we can help you to fix your issue.

Hopefully, others will see similar, and be resolved too.
If not the same, then AFTER we have that system fixed we can look at the next one.

Please bear with us.

It is highly likely that:
We did not supply your system (we are not Hikvision).
We are trying to find something that has gone wrong with YOUR setup.
 

Phil

Administrator
Staff member
Messages
2,967
Points
83
#20
@Tw27 and @Thegovernor I'm guessing you are in different time zones, please feel free to each create a new thread for the issue you are seeing, and I'll respond as soon as I can - leaving the office now.
 
Top