01304 827609 info@use-ip.co.uk Find us

iVMS4200 "sometimes" shows main streams not sub streams on startup. Causes network problems.

codlord

Member
Messages
34
Points
8
This issue is driving me mad. I really don't know why it's happening or what do do about it. Any help or suggestions appreciated.

Most of the time when iVMS4200 is started it shows my 7x7 grid of sub-stream feeds. Double-clicking on a stream shows a full-screen main stream. All well and good.

BUT...

"Sometimes" when iVMS4200 is started is shows my 7x7 grid but every feed is the main stream. And as all my cameras are 4k this floods the network and brings the PC running iVMS4200 to a slow grind. And sometimes it makes the PC so slow and unresponsive I struggle to even close iVMS4200.

Sometimes a close and re-start of iVMS4200 is all it takes to solve the problem but sometimes a re-start does exactly the same thing.

Due to the network flooding it also affects other PC's, apps, and other devices which may be monitoring cameras.

I have been having this same problem with many versions of iVMS4200 from 3.3.1.8 to latest 3.4.0.10_E I keep thinking it's a bug that Hikvision will fix but seemingly not.

iVMS is set to "Auto change stream" as it needs to be to be able to view small sub-streams in the grid view and main streams in full-screen view.
 

Yupowert

New Member
Messages
11
Points
3
I have a both a laptop & ipad with a 4G card, and WiFi, with the iVMS/Connect clients installed.
For me, if iVMS figures out it is on the same local network/subnet as my cameras (i.e when I'm connected using the LAN Wifi), it will connect to them in 'HD' (aka main stream). If not, (e.g I'm out using 4G, or on a remote network) then it defaults to 'BASIC' e.g. substream.

You could therefore create either
a) a subnet with a proper router
b) a sub-NAT if you've got an old/spare broadband/NAT/Wifi box.
Both will make your client appear to be on a 'remote' network, therefore it'll only request the BASIC substream from each camera.

I created the second by connecting up an old NAT box so its WAN connection was hooked up to my LAN, and its DHCP server was giving out a different IP Scope (e.g. 192.168.2.x) to new Wifi clients. When I connected my Laptop or iPad to that Wifi Network and used iVMS/Connect, I ALWAYS get BASIC substreams - If I want to view the main stream, I just click on the image and choose HD. (I think it also remembers this preference between sessions)

This may not be the solution you want, but it SHOULD give a definitive answer as to whether the auto-HD is due to it determining you're on the same network.

I used a BT HomeHub 5a with OpenWRT installed for my NAT Wifi.
 

codlord

Member
Messages
34
Points
8
@Yupowert that's great information, thanks. That could explain it if iVMS is thinking it's being clever and streaming main streams by default. Despite the fact that the problem is not consistent, but maybe it looks at network speeds or NVR streaming speeds or something like that at iVMS startup or something else that is not consistent.

I will have a check to see which PCs are on which networks...

EDIT: In the iVMS manual it states: "Auto-Change Stream Type - Camera selects stream type according to its display window size. When the window division number is smaller than 9, the stream type will be main stream, otherwise sub stream."
And as my window division is 7x7 (49) you would think that sub-stream should always be shown in the grid view...
 
Last edited:

Yupowert

New Member
Messages
11
Points
3
@Yupowert that's great information, thanks. That could explain it if iVMS is thinking it's being clever and streaming main streams by default. Despite the fact that the problem is not consistent, but maybe it looks at network speeds or NVR streaming speeds or something like that at iVMS startup or something else that is not consistent.

I will have a check to see which PCs are on which networks...
Just to add, that except for displaying the Channel-Zero stream (if you have it enabled), I'm fairly certain that on a local network, iVMS connects directly to each camera, not via the NVR.

I have the Channel-Zero stream active, as it gives an assurance of what the NVR is actually recording. I've had iVMS drop camera streams (and be fairly bloody minded about when/if it wants to reconnect), but iVMS would still show channel-Zero I could see that the NVR was still happily recording that particular camera, so obviously it wasn't a unit/network issue, just iVMS having a temper tantrum.
(The way to clear such issues in iVMS is often to either a) just switch to a different network - in my case between Wifi and 4G or b) to swipe/delete all the channel views in iVMS. In both cases, restarting iVMS caused it to perform a full reconnect with each camera, and restart its stream)
 

codlord

Member
Messages
34
Points
8
I tired the suggestion by @Yupowert - moved the PC from the camera network to a different network/subnet but it made no difference to my problem. I started iVMS several times - sometimes it showed all sub-streams (correct). Sometimes it showed the first 5 as main streams and all the others as sub-streams (not correct but does not cause the network to be completely swamped). And sometimes all streams showed as main streams and therefore network completely swamped.

If anyone has any other ideas why iVMS may be choosing to show main streams in the grid view I would love to hear them!

The only options seem to be manually choosing a stream (but then that stream is shown in the grid view AND the full-screen view), or the auto change stream option which I have selected for each stream.
 

JB1970

Well-Known Member
Messages
668
Points
63
In iVMS-4200 - Tool > System Configuration > Live View and Playback - have you got the "Resume latest live view status after restart" box checked? If so it would always reconnect to the cameras as they were when you last closed the software. You would have to either uncheck that box and start the streams manually after starting the software or ensure that you reselect the sub stream on all cameras before you close it down.
 

codlord

Member
Messages
34
Points
8
@JB1970 Yes the "Resume latest live view status after restart" is checked as I want it to be as simple for the (non-techie) user but it does not always resume to the same state, like I said, sometimes it shows all sub-streams, sometimes some main streams and sometimes all main streams.

But maybe it's something I should look into - disable that setting and make the user always double click on the pre-defined view setup. Maybe that will help. I will give it a go...

I know you can manually select the sub-stream in the grid view but then if you do that when the user double-clicks a stream in the grid it will show the (640x480) sub-stream in full-screen (in my case 4k screen) which is useless to the user. The user can of course right-click and choose the main stream but then it will always show the main stream in the grid view.

I don't understand why on this particuar PC I get the problem but on my own PC with the same setup I don't get the problem - I automatically see sub-streams in grid view and main streams in full-screen view.
 

JB1970

Well-Known Member
Messages
668
Points
63
@JB1970 Yes the "Resume latest live view status after restart" is checked as I want it to be as simple for the (non-techie) user but it does not always resume to the same state, like I said, sometimes it shows all sub-streams, sometimes some main streams and sometimes all main streams.

But maybe it's something I should look into - disable that setting and make the user always double click on the pre-defined view setup. Maybe that will help. I will give it a go...

I know you can manually select the sub-stream in the grid view but then if you do that when the user double-clicks a stream in the grid it will show the (640x480) sub-stream in full-screen (in my case 4k screen) which is useless to the user. The user can of course right-click and choose the main stream but then it will always show the main stream in the grid view.

I don't understand why on this particuar PC I get the problem but on my own PC with the same setup I don't get the problem - I automatically see sub-streams in grid view and main streams in full-screen view.

Yeah it was just a thought. Maybe select main stream on off numbered cameras, sub on even numbered before closing it next time and see what results you get when reopening.
 
Top