• Hi Guest, Please subscribe to our YouTube channel for fresh new videos each week.

Latest HikVision Firmware for EasyIP 3.0 Cameras - new V5.5.82 (G1 Series cameras)

risrjs

New Member
Messages
3
Likes
1
Points
3
#2
Hikvision have released new firmware for their G1 Family cameras - V5.5.82
Currently I am only seeing this at their UK download portal here:
HIKVISION UK PORTAL

The Release Notes are attached
Need to go through EU portal then Technical Materials for a different path (I don't know why). 5.5.82 has been there for some time.
 

Phil

Administrator
Staff member
Messages
2,221
Likes
189
Points
63
Thread starter #3
That's interesting.
Thanks for sharing.
We had not noticed that route/additional location for firmware.

It is currently 'all a bit of a mess' - with all these different locations (occasionally, different/newer versions are available at their website(s) too).

Longstanding EU Portal firmware location - DOWNLOAD EU PORTAL
Recently created UK portal location - HIKVISION UK PORTAL
This new location for firmware within the EU portal "Technical Materials" sub-section - DOWNLOAD EU PORTAL
Their websites - Pro Series(EasyIP) - Firmware Download - Hikvision
(navigate via Support -> Downloads -> Firmware -> then select your device type from the sub-header)
[NB - what is offered at the Hikvision websites varies according to which region you select]

Currently, the Hikvision UK website simply returns a "Coming Soon!" message via this route:

1547532181207.png


For the sake of the above message I'll take this opportunity to re-state that use-IP Ltd are an Authorised Hikvision Partner in the UK.

We'll have a look around later and see if there are any new 'latest' versions at any of these locations that we are not yet pointing to.
We'll update our various 'Latest version' posts here in the forum as and where necessary.

As ever, if anybody spots a newer version than we are suggesting in our forum posts, we'd be grateful if you could point it out to us ASAP, thanks.

NB - All our "Latest version" Posts are 'sticky' within the Hikvision sub-forum - this simply means that they always stay in the top 'pinned' section regardless of daily new entries e.g. other new Threads started or updated each day.
 
Last edited:

Amertat

New Member
Messages
5
Likes
1
Points
3
#4
Hi,
i test this firmware and confirm that as the changelog says the sub-stream (in Firmware v5.5.80) problem was fixed.
i upgrade all camera since 10 days ago no problem.
 

Infosec

New Member
Messages
3
Likes
0
Points
1
#6
Installed Firmware v5.5.82 and can confirm the update fixed the sub-stream issue with v5.5.80
Going to update the NVR now I know the above has been fixed.
 

hiky

New Member
Messages
1
Likes
0
Points
1
#7
just joined because this was the only place that seems to know about HIKS and fw... i just installed the .82 fw on one of my 2335fwd cams as a test but got no web component image ?? seemed the fw didnt like my cam, i jumped from .51 to .82 no idea if that was the cause, so downgraded back to .51 for now

just wandering if you guys have any thoughts on why the fw upgrade seemed wrong

Had another crack at it this morning and at least on my DS-2CD2335FWD-I/G the latest FW didnt want to play ball properly, as well as no web components image, in settings the top option ( Local ) was not auto filled in after upgrade reboot, if the items were filled in and save was selected, no saved message appeared, exiting Local and returning showed all sections un selected, so nothing was being saved in that section... and further still after a reset of the cam Local option was then missing, another concern was the FW Upgrade Browse option failed to bring up a browser window to select a new digicap, using a different browser luckily did show the browse window for a fw upgrade and i was able to downgrade again back to .51without issues

The cam itself is an official Uk Hik cam from another authorised reseller and has never shown any signs of issues with FW upgrades, only this version

browsers used Palemoon, Microsoft Edge 42.17134.1.0 and the latest FF

A bit frustrating as i do like to run the latest FW
 
Last edited:

Phil

Administrator
Staff member
Messages
2,221
Likes
189
Points
63
Thread starter #9
Yes, please test with the Internet Explorer browser.
You should be fine with V5.5.82 firmware.
 

GravityRZ

New Member
Messages
6
Likes
0
Points
1
#10
I installed the latest 5.5.82 FW.

i noticed that explorer works and uses stream 1 when logging in.
Chrome however also works but defaults to stream2(substream)
also i can change the screen settings(16:9) and stream 1 but i have to do this every time after logging in.

did nobody else noticed that stream2 is selected in chrome(with low res stream)
 

Dan

Administrator
Staff member
Messages
80
Likes
7
Points
8
#11
did nobody else noticed that stream2 is selected in chrome(with low res stream)
Hi,

We were aware of the ability to switch to main-stream in chrome with the latest firmware, but it is still only a partial fix to the browser plugin issue because when you view through chrome on the latest firmware you lose the Playback & Picture menus at the top of the page, which means you can't actually playback footage via the Chrome browser.

It is a step in the right direction though and we hope that around the end of Q1/start of Q2 we will see an update that will allow full 'no plugin' access via all browsers.
 

GravityRZ

New Member
Messages
6
Likes
0
Points
1
#12
i do not see any picture/playback menu's at the top. are these perhaps nvr buttons.(which i do not have)

i only have these at the bottom right side

1551719914626.png


and these at the bottom left

these should remember settings as well (16:9 should stick and stream 1 should stick)

1551720063466.png
 

Dan

Administrator
Staff member
Messages
80
Likes
7
Points
8
#13
i do not see any picture/playback menu's at the top. are these perhaps nvr buttons.(which i do not have)
The playback & picture menus should appear whether it is a camera or NVR (see photo below of one of our office cameras when accessed using Internet Explorer), if you are not recording directly to the camera using a MicroSD card then not having this menu isn't a big deal as you should still be able to access your recordings from the other device you are recording to. If you are recording to the camera then the only way you will be able to access your recordings is to use Internet Explorer or setup iVMS-4200 and manage your camera through that software.

IMG_20190305_094430.jpg


The fact that the camera doesn't default to main-stream as it does in Internet Explorer is part of this partial 'no plugin' fix that Hikvision have implemented with the latest firmware, you can now stream your camera via chrome but in getting this to work Hikvision have had to compromise other features of browser access like the playback/picture menus and the ability to default to main-stream. (this is probably because their current 'no plugin solution struggles with the high resolution of the main-stream and so defaults to the sub-stream - we tested an 8MP camera here in the office using Chrome and we couldn't access it's main-stream so it would appear to only work with 5/6MP cameras and below)
 

GravityRZ

New Member
Messages
6
Likes
0
Points
1
#14
thank Dan, clear now. i noticed the buttons on explorer(and the lack of it in Chrome)

by the way i loved your reviews on the hikvision camera's. I first bought the 2CD2455FWD(5MP but settings go up to 6MP) but that one was not that good.
it turned out it has a flat lense which is succeptable to reflections( i have a lot of windows)
i now have the 2CD2463GO( 6MP)which has a better lense(not flat)
amazing night view
 

pyrotenax

New Member
Messages
10
Likes
3
Points
3
#15
Forgive my n00b ability ...
Can someone please tell me which firmware files are the latest for my cameras ...

1)DS-2DE4225IW-DE

2) DS-2CD2385FWD-I

many thanks
 
Top