• Hi Guest, Please subscribe to our YouTube channel for fresh new videos each week.

Latest HikVision Firmware for G1 Series cameras - version V5.6.2

Are you satisfied with this firmware update?

  • Satisfied

    Votes: 5 83.3%
  • Not satisfied

    Votes: 1 16.7%

  • Total voters
    6

Phil

Administrator
Staff member
Messages
2,967
Points
83
Thread starter #1
Update 21st November 2019 - Superseded by V5.6.3:

Hikvision have released new firmware for their G1 Series IP cameras version V5.6.2

This can be downloaded from their portal here:
European portal - DOWNLOAD EU PORTAL
UK portal - N/A yet

NB - you may need to refresh your browser when viewing the Hikvision portal to see the newly added version at the bottom of the list.

The Release Notes are attached.

The last few pages of the release notes specify the applicable cameras.

This release deals with just two specific updates, most notably the issue that many users who use a NAS for recording their Hikvision cameras were experiencing:

Hikvision Firmware V5.6.2 Features

*for G1 platform Cameras

1. New Features
  • Fixed the issue that port mapping only take effect after rebooting device. (Port of Enhanced SDK service, WebSocket, WebSockets)
  • Fixed the issue that only 80GB capacity of NAS storage are available when camera mount to NAS server (more than 80GB) and enable overwrite.
 

Attachments

Last edited:

jarmour

New Member
Messages
11
Points
1
#3
Just tried to update a new camera to this firmware version (presently on 5.5.71). Downloaded, expanded zip file, navigated to expanded file but on pressing 'Upgrade' get message "failed to upgrade....". Any ideas how to fix?
 

Amertat

New Member
Messages
26
Points
3
#4
Just tried to update a new camera to this firmware version (presently on 5.5.71). Downloaded, expanded zip file, navigated to expanded file but on pressing 'Upgrade' get message "failed to upgrade....". Any ideas how to fix?
could you please indicate which model you are using?
 

jarmour

New Member
Messages
11
Points
1
#5
The model is DS-2CD2346G1-I. It's on page 12 of the list attached to the release notes.
 

Dan

Administrator
Staff member
Messages
459
Points
28
#6
The model is DS-2CD2346G1-I. It's on page 12 of the list attached to the release notes.
I believe this is a mistake by Hikvision in the release notes, the 2346 is actually part of the G1+M Firmware Family (2xx6) which is only for AcuSense cameras. The latest version of that firmware is v5.6.0

I checked the release notes on that firmware and it looks like Hikvision are actually using the same release notes for both versions of the same firmware, I assume it is the case that currently the AcuSense, ColorVu, and EasyIP 3.0 cameras all use the same firmware but they have already split the AcuSense cameras into their own family of firmware because they expect those cameras to require unique firmware in the future to update the AcuSense features and the ColorVu and EasyIP 3.0 cameras will not support these future updates.
 

jarmour

New Member
Messages
11
Points
1
#7
Thanks very much Dan. Downloaded that version and updated fine. I can now get the 'Playback' and 'Picture' menus (using Opera as run on a Mac) - though Playback doesn't actually work even though there are incidents triggered which I can view on the app - and Pictures finds no files to download (I assume that any recorded incidents should be able to be downloaded). Still can't get email alerts to work - separate post last night.

However - firmware query solved!
 

Dan

Administrator
Staff member
Messages
459
Points
28
#8
Thanks very much Dan. Downloaded that version and updated fine. I can now get the 'Playback' and 'Picture' menus (using Opera as run on a Mac) - though Playback doesn't actually work even though there are incidents triggered which I can view on the app - and Pictures finds no files to download (I assume that any recorded incidents should be able to be downloaded).
Good to hear, the playback issue may simply be a browser issue. Hikvision recently improved browser compatibility for EasyIP 2.0+/3.0/4.0 cameras as they only used to support Internet Explorer, but with the update, you should be able to access the camera from Chrome, Firefox, and Safari. The section in the datasheet that refers to this (see below) does not list Opera as an option so it may be that this browser is still not fully compatible, try one of the other browsers and see how you get on.

2567
 

jarmour

New Member
Messages
11
Points
1
#9
I've been trying all sorts of browsers, Chrome and Firefox among them but always the same problems. Never thought of Safari as the old camera hasn't worked with that for ages - have just tried it now and it's the same there as with the other browsers I've tried - Playback shows incidents are there but just comes up with "playback failed" when I try to view (but I can get review them on the iOS app). Funnily enough with Safari I can download the files, which I couldn't do with Opera (not reed that with Chrome or Firefox) - but Quicktime (and any other equivalent application I have) won't recognise the mp4 file - aargh!

On the email side of things I still can't get it to send a test email ( I have tried three or four different addresses on different servers) - I can do this through iVMS but in that program I can't get the software to add the camera to a feed at all! It's all a bit odd as with the previous camera (EasyIP 2.0+ one) if I changed configuration in the browser, the change was seen in iVMS and vice versa but saving the working test email parameters in iVMS with this camera doesn't get reflected in the browser configuration. I presume it's because iVMS isn't properly recognising the camera - who knows? I think I'll have to find someone with a Windows laptop and try Explorer at this rate.
 

jarmour

New Member
Messages
11
Points
1
#10
Dan - fixed email problem with Phil's help on another thread. However, after the reboot required, Playback and Pictures have vanished from all browsers once more (Safari/ Chrome/ Firefox/ Opera and Seamonkey - tried them all!). Since both menus appeared after having installed v5.6.0, I reinstalled that but still nothing - any ideas?
 

Dan

Administrator
Staff member
Messages
459
Points
28
#11
Dan - fixed email problem with Phil's help on another thread. However, after the reboot required, Playback and Pictures have vanished from all browsers once more (Safari/ Chrome/ Firefox/ Opera and Seamonkey - tried them all!). Since both menus appeared after having installed v5.6.0, I reinstalled that but still nothing - any ideas?
You may need to clear your browser caches to view everything correctly
 

Amertat

New Member
Messages
26
Points
3
#12
Dan - fixed email problem with Phil's help on another thread. However, after the reboot required, Playback and Pictures have vanished from all browsers once more (Safari/ Chrome/ Firefox/ Opera and Seamonkey - tried them all!). Since both menus appeared after having installed v5.6.0, I reinstalled that but still nothing - any ideas?
press Ctrl+F5 on related web page to clear cache content and refresh.
 

jarmour

New Member
Messages
11
Points
1
#13
Cleared cache in Safari, Chrome and Firefox - all the same on restarting - just Live View and Configuration in all of them, so back to where I was on first setting up the camera, prior to updating to newest firmware. Have tried reloading that too but no change, still just the two menu options.
 

fullboogie

Active Member
Messages
230
Points
28
#16
ftp:/ftp.hikvision.ru/

ftp:/ftp.hikvision.ru/02.%202-line%20cameras/4.%20G1%20platform%20-%20DS-2CD2XX5%202XX3G0%202XX7G1/IPC_G1_EN_STD_5.6.3_190923.zip
 

Phil

Administrator
Staff member
Messages
2,967
Points
83
Thread starter #17
Whilst that download / version may be fine, we have to counsel caution before updating to versions from Hikvision's other global sites i.e. we don't think we would get much sympathy from Hikvision UK Support if problems arise from a version that they have not yet made available at the UK / European portals.

Even with the UK/EU portals we have seen versions posted then subsequently taken down.
 

fullboogie

Active Member
Messages
230
Points
28
#19
Good catch Phil. Honestly I did not notice it was from Russia, I was just excited to see some new firmware.

Does this likely mean that Europe/US will get this version soon?
 

Phil

Administrator
Staff member
Messages
2,967
Points
83
Thread starter #20
Yes, it's likely it will appear at our portals soon :)
 
Top