01304 827609 info@use-ip.co.uk Find us

Firmware Latest HikVision Firmware for I-Series NVRs - V4.40.015 build200616

Kyle

Administrator
Staff member
Messages
255
Points
28
Hikvision has released new firmware for their I-Series Network Video Recorders. The latest firmware, V4.40.015 build200616, can be downloaded here.

NB - you may need to refresh your browser when viewing the Hikvision portal to see the newly added version at the bottom of the list.

The Release Notes are attached.

The last couple of pages of the release notes specify the applicable NVRs.

Reason of Upgrade

Add new features and optimize product performance.

New features

1.【Support adding motion detection 2.0 IPC】
2.【Support adding audio and light alarm IPC】
3.【Support Hik-Connect to enable One-Key Do Not Disturb function】
4.【Support Hik-Connect / GuardingVision to scan NVR QR code to recover password】
5.【Support local decoding multi-track streams UHD resolution IPC】
6.【Support thermal camera temperature measurement alarm】
7.【Support thermal cameral face temperature alarm】
8.【Support IPv6 network】
9.【Increase log storage period】

Modified functions

1.【Optimization of bandwidth performance】
2.【Optimization of search performance】
3.【Optimization of WEB Live View interface】

Fixed issues

1.【Fix the issue that the sub-stream cannot be accessed】
2.【Fix the issue that Hik-Connect cannot be connected】


NB - There do not appear to be any differences between these release notes and those for V4.40.010 build200430. We'll ask Hikvision for more information on what's been updated in this version and update you with what we can below in this thread.

We've noticed that, unfortunately, this upgrade hasn't fixed the long-standing issue of the missing 'Local' menu in the browser interface for macOS users.

Regardless, we recommend that you always update to the latest firmware available for your NVR.

We'll update you with any of our own findings as we continue using this new firmware. As always, if you have updated and have any feedback to share below, it's always appreciated!
 

Attachments

KamirZG

Member
Messages
41
Points
8
Hi Kyle. Do you know what's the difference between EU portal and UK portal? On EU portal you can't find this FW, you can't even find this FW on hik web-page of the product. Latest FW that you can find on EU portal and NVR we-page is 4.22.005.

I'm slightly confused by this.
 

Dan

Administrator
Staff member
Messages
1,056
Points
63
Hi @KamirZG

There is very little difference between the UK & EU portals, we have often used/recommend EU portal firmware if it is newer than what is available at the UK portal. The only reason they really exist as separate portals is that there are some product ranges that are only available in mainland Europe like the AcuSense NVRs and E(x) Platform 1-series cameras. (e.g. E0 Civil, E6, E7 Platform)

But whether you are UK or EU-based, whichever portal has the latest firmware for a particular model should be fine to use on both UK & EU products.
 

KamirZG

Member
Messages
41
Points
8
Hi @KamirZG

There is very little difference between the UK & EU portals, we have often used/recommend EU portal firmware if it is newer than what is available at the UK portal. The only reason they really exist as separate portals is that there are some product ranges that are only available in mainland Europe like the AcuSense NVRs and E(x) Platform 1-series cameras. (e.g. E0 Civil, E6, E7 Platform)

But whether you are UK or EU-based, whichever portal has the latest firmware for a particular model should be fine to use on both UK & EU products.
Great, thanks.
 

Yupowert

New Member
Messages
5
Points
3
I've just installed it 48 hrs ago directly onto my new second DS-7616NI-K2/P1 - and it's working great. No crashes etc. As it is a new unit, I did a factory reset and camera import after upg.

For me, even though I only use it via the web interface, I immediately see 2 advantages
1) I can use Edge(v2) or Chrome browsers directly - and the playback is liquid smooth with no CPU overhead, even on main stream live view of 11 cams
2) Cameras which are occasionally disconnected remain in the list on the live preview. - This prevents the "Live View Shuffle" as it inserts blank video squares rather than moving later camera views into them. (I have some remote solar powered wifi cams which can go offline)

For those interested in the details of the build differences, here are the info pages from both - one running V4.40.015 and the other V3.4.109

1593844207541.png
1593844382541.png


I'll be running split firmware versions for the next month, to assess v4.40's long term stability on the DS-7616NI-K2/P1, and then upg the other one after that.
 
Last edited:

Yupowert

New Member
Messages
5
Points
3
You've got a K series and this is for an I series. Does the K use the same firmware?
I don't know whether it's THE SAME firmware, but it's certainly compatible - how much, and whether there's any underlying long term issues/incompatibilities, well that's for each individual to find out. It's not recommended/promoted/claimed/suggested or mentioned by Hikvision, but others have done this upgrade path in the past - some with, some without issues.

I can only comment on my setup, which so far is working fine. However, I don't claim to use anything like all the features, bells and whistles - and the gremlins often live in those specific functions!

You can always downgrade it back to v3.4 if it doesn't work out for you - but you'l need to do a Factory Reset after (if it doesn't do it anyway). So before you attempt this upgrade, take a backup/export first, then take photos of every setting you've altered, and options you've enabled, so you CAN get back to where you started if required.

Hope that helps
 

fullboogie

Active Member
Messages
424
Points
28
Appreciate the explanation but I have an I-series. I've just seen way too many K-series owners accidentally upgrade with I-series firmware and have tons of problems. Good luck.
 

windie

New Member
Messages
10
Points
3
Happy with this upgrade. With 3 cameras I had 'no resource' only during playback mode, using lan port 1,2,3. If for eg I plugged the cameras into 1,2 and 4 then 2 cameras would work in playback mode, 3rd would show no resource. Didnt bother as I use ivms4200.

Now all is good and smooth even with 4 cameras on. No issues with playback.
 

Yupowert

New Member
Messages
5
Points
3
Appreciate the explanation but I have an I-series. I've just seen way too many K-series owners accidentally upgrade with I-series firmware and have tons of problems. Good luck.
I'll keep you (all) posted ! (In a few weeks when I do my other 7616-K2/1P
So far 11 Cams, (8x2MP 3x4MP, - 9 hardwired, 2 WiFi) (None are PTZ or Audio) all working fine. Web interface great (Not using the direct interface). Basic Motion Event detection setup and working. Playback of all cams good. No crashes, no weirdness.
Fingers crossed!
 

fredkruger

New Member
Messages
21
Points
3
With this version & using hik connect app for Android, I'm still unable to playback alarm notifications from the playback button in the notification window.
Also when playing back from the time line using hik connect app the the recorded alarm events are not shown and skipped, even though they are in the middle of a motion event..
It's like nothing was recorded during the alarm input event.
Luckily video is reorded but I'm only able to view via locally connected monitor...

This is a major problem for me, but I'm guessing not so many people use the alarm input triggers on the NVR?
 

windie

New Member
Messages
10
Points
3
With this version & using hik connect app for Android, I'm still unable to playback alarm notifications from the playback button in the notification window.
Works fine for me. Do you have the latest hikconnect app?

In playback it doesnt show itself on the timeline bar. But under it you can view events, it will sort events date wise for that camera.
 

fredkruger

New Member
Messages
21
Points
3
Thanks for the info I thought I had the latest version as I only upgraded a few weeks ago and the app even said it was the latest version under "detect new version"

Anyway I was hopeful for this solution, but still it didn't solve my problems.

i can view the alarm event on the timeline using Windows 10 browser... But still missing via app
 

fredkruger

New Member
Messages
21
Points
3
I think I can see where the problem is
If I login to
https://www.hik-connect.com/ via browser, my IP address is not being updated my my NVR.

If I login to my NVR configuration using a browser, under Network>advanced settings>platform access Register Status it shows "Offline"
I think the server address has changed during the last firmware update.

under Platform access Server Address I have
"dev.hik-connect.com"
it did have something else which I can't remember now which also didn't work


What is everyone else using for server address?
 

barrie

New Member
Messages
4
Points
3
I've just installed it 48 hrs ago directly onto my new second DS-7616NI-K2/P1 - and it's working great. No crashes etc. As it is a new unit, I did a factory reset and camera import after upg.

For me, even though I only use it via the web interface, I immediately see 2 advantages
1) I can use Edge(v2) or Chrome browsers directly - and the playback is liquid smooth with no CPU overhead, even on main stream live view of 11 cams
2) Cameras which are occasionally disconnected remain in the list on the live preview. - This prevents the "Live View Shuffle" as it inserts blank video squares rather than moving later camera views into them. (I have some remote solar powered wifi cams which can go offline)

For those interested in the details of the build differences, here are the info pages from both - one running V4.40.015 and the other V3.4.109

View attachment 4024View attachment 4025

I'll be running split firmware versions for the next month, to assess v4.40's long term stability on the DS-7616NI-K2/P1, and then upg the other one after that.
How did you get this on a K series I have an 8p K series running the last version V4.22.000 build 190821 but cant take it to anyother as i was aware hik pulled the k series from gui 4
 

fredkruger

New Member
Messages
21
Points
3
litedev.sgp.hik-connect.com
Thanks, I tried "litedev.sgp.hik-connect.com"
But my NVR changed it to "litedev.eu.hik-connect.com"...
Anyway it works and my IP address updates within the hik connect cloud now.

Unfortunately the alarm input notifications are still not playable from the hik connect app.
 
Top