• Hi Guest, Please subscribe to our YouTube channel for fresh new videos each week.

Firmware Latest HikVision Firmware for K-Series [76NI-K1(B)] NVRs - V3.4.109

Kyle

Administrator
Staff member
Messages
219
Points
28
Thread starter #1
Hikvision have released new version 3 firmware for their K-Series [76NI-K1(B)] Network Video Recorders. The latest firmware, Version 3.4.109, can be downloaded here.

NB - you may need to refresh your browser when viewing the Hikvision portal to see the newly added version at the bottom of the list.

I'll follow up with release notes as soon as they're available.

We always recommend you update firmware whenever a new version is released as this often helps fix all manner of problems you might be experiencing while ensuring the security of your device.
 
Last edited:

andrewd

New Member
Messages
2
Points
1
#2
Hi Kyle,

Is this firmware version compatible with DS-7608NI-K2 ?
 

Phil

Administrator
Staff member
Messages
3,470
Points
83
#3
No, sorry, 7604 K1 (B) only.

The latest for your model is currently V3.4.108
 

Dan

Administrator
Staff member
Messages
930
Points
43
#5
Hi @pepeEL

The version you have linked to on the Russian FTP portal is a newer build than the version linked above but we would still recommend sticking to the UK/EU version that is linked above because different builds sometimes have regional specific updates and tweaks.
 

Carphone

New Member
Messages
10
Points
3
#6
Hi,

Will this Version 3.4.109, work with the DS-7604NI-K1/4P(B) NVR model?

Only reason i ask is that the hikvision page below suggests the latest version for this NVR is a lower build of : K74 V3.4.104 build190424 . Maybe their page is out of date?


Thanks very much!

Dan
 

Dan

Administrator
Staff member
Messages
930
Points
43
#7
Hi @Carphone

Yes, that v3.4.109 firmware is in the 7604(B) folder on the Hikvision UK portal so that is fine to use, the latest firmware is always found at the portal
 

binded2

New Member
Messages
3
Points
1
#9
ok so things are not very clear for me as i have a no name oem theres no branding
Item No.: NVR108MH-P8
DS-7608NI-K1/8P(B) vers 3.4.100 system and cant seem to find updates for it




looks some what like the 4P(B) and 8P(B) are the same thing
what update do i use
and what is the upgrade path as hikvisions site says to do them going up i wouldn't want to have to flash 5 firmware's


this is the first site that i have seen had any sorta info on the
i hoping that upgrading will allow me to use the h265+ as when i set it in the cam the nvr doesn't turn it on its greyed out


i also found this seems to be 2020 from feb
3.4.110 2-12-2020

if i upgrade will the nvr get branded or no

ok for now as i cant get my thoughts str8
 
Last edited:

Dan

Administrator
Staff member
Messages
930
Points
43
#10
Hi @binded2

Updating firmware for OEM products is not always simple as they don't always support the latest firmware of the original Hikvision product, if the model you have is a rebadged 7608NI-K1/8P then the latest firmware will likely be v3.4.109 but as I say it is not guaranteed that all OEM products will support the latest firmware and as well it may rebadge the NVR's GUI as Hikvision which may cause problems as features of the Hikvision-specific firmware clash with the unique OEM firmware.

Another slightly older firmware you can try that may be more broadly compatible with the OEM models would be v3.4.104

If you have any issues with the above then my advice would be to try and contact the OEM brand and get there advice.
 

Caesium

New Member
Messages
1
Points
1
#11
Following this with interest as I have a DS-7608NI-K2 /8P running v4.21.005 firmware with no issues at all.

Cant even remember when I upgraded it.
 

binded2

New Member
Messages
3
Points
1
#12
Hi @binded2

Updating firmware for OEM products is not always simple as they don't always support the latest firmware of the original Hikvision product, if the model you have is a rebadged 7608NI-K1/8P then the latest firmware will likely be v3.4.109 but as I say it is not guaranteed that all OEM products will support the latest firmware and as well it may rebadge the NVR's GUI as Hikvision which may cause problems as features of the Hikvision-specific firmware clash with the unique OEM firmware.

Another slightly older firmware you can try that may be more broadly compatible with the OEM models would be v3.4.104

If you have any issues with the above then my advice would be to try and contact the OEM brand and get there advice.
so the update worked it with 104 and 109 the 110 worked but then i couldnt add any cameras says illegal something

104-109 work and seems towork great but for i keep getting no resource on the nvr hdmi output on at least two cameras
having set all liveview windows to sub streams results in failure on all outputs and in settings. the out puts switch up and change but only two a time work on the screen.
2 of 4 so half of them like a post above.

so substreams are broken nvr reports theres no substreams but all of them cameras have them and working
i did rebrand to hikvision btw

i read a few up that people lost outputs any fixxes

im back in contact with anpviz about it as well trying to see if getting the firmware that came with it is more functional or not
i did try resetting all settings but for user and network settings

Following this with interest as I have a DS-7608NI-K2 /8P running v4.21.005 firmware with no issues at all.

Cant even remember when I upgraded it.
wish that i had the k2 seems all the updates are for that and none for the k1
 

binded2

New Member
Messages
3
Points
1
#13
after alot of fighting with the unit seems like its working right now in the end i ended up doing the flash to 109 again and then factory resetting every thing users and network settings and unlinking it. after a reboot and a few beeps and hooking it back up to vga so i could use the mouse and set it up seems to be working no more resource problems. as well as the NVR is no longer telling me theres no subs streams on the cameras

although the h265+ still does not work in the cameras i can set it and i can see in the video streams osd thats its set nvr only h265 the + is greyed out or in the web interface not there at all
 

ndabar

New Member
Messages
2
Points
1
#14
hi folks,
I have updated DS-7608NI-K1(B) from the default firmware V3.4.99_build171121 to the latest one V3.4.110_build200212.
Now using Hik-connect I can only see the 3 hikvision cameras and the other 2 cameras with RTSP are not shown/linked. Any idea why?
From the NVR the other 2 cameras are visible and stable, later I have tried 2 other mobile apps, Ezviz and iVS-4500. With iVMS-4500 i can list and stream the rtsp cameras, so I am bit confused here!

Is it possible to do a firmware rollback?
 

Phil

Administrator
Staff member
Messages
3,470
Points
83
#15
It is best to use the latest firmware.
Try cycling the power to the NVR.
 

ndabar

New Member
Messages
2
Points
1
#16
It is best to use the latest firmware.
Try cycling the power to the NVR.
yes normally for security reasons, but at this point I can't track my cameras with the usual app, hik-connect, although I can with iVS-4500, i know that is hikvision technology behind. Perhaps is matter of preference.

Still, is it possible to do a rollback with the NVR? Thanks
 

Gazm1954

New Member
Messages
1
Points
1
#17
yes normally for security reasons, but at this point I can't track my cameras with the usual app, hik-connect, although I can with iVS-4500, i know that is hikvision technology behind. Perhaps is matter of preference.

Still, is it possible to do a rollback with the NVR? Thanks
Did anyone get an answer to this, since updating I have lost hikconnect access to my Cam4, working fine in IVS. Its not a camera problem as I can swap the cameras connections round and all are working fine, it's just cam4 port which isn't talking to Hik Connect
 
Top