• Hi Guest, Please subscribe to our YouTube channel for fresh new videos each week.

New version 4 Firmware for HikVision NVRs

Status
Not open for further replies.

Phil

Administrator
Staff member
Messages
1,691
Likes
127
Points
63
Thread starter #1
HikVision have released new V4 firmware for some NVR ranges today.
It's a big change to your user interface, so you might want to set some time aside (and maybe wait a few days for feedback from the pioneers) before making this update!

Hikvision_NVR_4-0_file_management_2017.jpg


As ever, the latest firmware for your HikVision NVR is available at their European Downloads portal: DOWNLOAD PORTAL

Their Press Release can be read here.

At the moment this new version is only available for suffix '-I' NVRs.

It's unclear what HikVision mean by this comment in their press release - "Older devices will also be to benefit from the new firmware"


upload_2017-11-10_16-38-24.png


The Release Notes are below.

Update 12th December - HikVision provided updated manuals & guides for reference with V4 firmware - added below.

Superseded Update 26th March 2018 - HikVision have released a newer V4 firmware version:
Latest HikVision Firmware for -I NVRs - new V4.1.50 (76XX, 77XX, 96XX NI-I)
 

Attachments

Last edited:

Phil

Administrator
Staff member
Messages
1,691
Likes
127
Points
63
Thread starter #2
As it's not yet clear whether -K and other HikVision NVR models will receive this update we have added a note to each NVR's product page in our webshop this afternoon pointing potential buyers to this thread for the latest information.

If you have feedback on the new V4 Firmware for HikVision NVRs, please do post a response below.
 

Phil

Administrator
Staff member
Messages
1,691
Likes
127
Points
63
Thread starter #3
Upgrade / downgrade for testing?
Just FYI - our demo HikVision 7716NI-I4 was running V3.4.95 firmware.
I updated it to V4.1.10
Then downgraded it to V3.4.96 firmware.

The upgrade went well, I only had a very quick look around.
The downgrade has caused problems - our NVR is reset to inactive AND bleeping for an HDD format!
The downgrade caused it to completely reset to factory defaults; IP addresses, camera setup and other settings all reset.
I didn't have to reformat the HDDs, after resetting a few parameters the bleeping stopped and I was able to review previously recorded video.
So, it does seem possible to upgrade/downgrade, but not without some re-configuring.
I would recommend that you export your parameters before updating just to be cautious.

Export parameteres 10-11-17.png
 

Phil

Administrator
Staff member
Messages
1,691
Likes
127
Points
63
Thread starter #4
If you normally use the web interface i.e. access your NVR via your browser, then you will only see minor improvements.
Whereas, if you normally access your NVR via a direct-connected monitor, mouse & keyboard that user interface has had a complete makeover. It's certainly worth a look - too many changes to begin to investigate at 5:30pm on a Friday ;)
 
Messages
6
Likes
3
Points
3
#5
Ok, so I updated.

I was 2 versions behind the v4 and updated to v4 direct.

The update was easy enough and worked but somehow my 2nd account the username ended up as a showing a password, not the username.

Updated this with an edit on both username and password and all has been ok. All other settings look as they were before and correct

I do like the new look just need to get around to using it more.

Updated camera's to the latest update all worked well.
 

Phil

Administrator
Staff member
Messages
1,691
Likes
127
Points
63
Thread starter #8
Hi, Can you clarify your query a little more for me please?

If you want to use their Hik-Connect portal, then (in V4) you still need to enter a Verification Code.

Hik-Connect verification Code 22-11-17.png



Create Verification code for Hik-Connect 22-11-17.png


You can use other DDNS services without the verification:

HikVision other DDNS 22-11-17.png
 

malford

New Member
Messages
20
Likes
10
Points
3
#9
Hello Phil.
The NVR is connected and configured to work with Hik-Connect but not used to view live footage, instead I am using the Asus port forwarding facility on my RT-AC87U router which works very fast (Hik-Connect was way too slow when tested with iVMS 4500)

I had several users who could not connect and when I checked the “encrypted stream” setting it had magically switched itself on after I had switched it off..

I like the idea of using the NVR to configure advanced parameters on my ANPR camera rather than using the web interface.

I’ll give it a go and report back with my findings.. thank you
 

Attachments

Last edited:

malford

New Member
Messages
20
Likes
10
Points
3
#10
Upgrade completed in 10 minutes and all cameras detected automatically.
Only issue so far is the ADMIN account password has been changed during the upgrade which is a bit of a headache as I now can’t access remotely and to add or edit a user I need the password lol.
I’ll figure it out.
 

Attachments

malford

New Member
Messages
20
Likes
10
Points
3
#11
The password database must of got corrupted during the upgrade and unfortunately the 2x backup GUID files I saved did not reset the admin password and I never set a security question ( I have now).

Maybe the corruption had something to do with me disabling the password prompt prior to the upgrade which was why I was able to locally control the NVR.
Anyway did a full factory reset and the setup wizard did its job and prompted me to change the password and I regained full access.

First impressions are its slicker than the old GUI but my first disappointment was no fast access drop down menu with a right clink of the mouse (Parameters/plate search etc)
The full screen display no longer switches to next camera with the mouse scroll wheel which is another feature I used a lot.
The full screen image settings menu button has also vanished.

It would also be nice if in the next firmware update they could have a screen calibration setting when viewing via HDMI on a Panasonic VT 65” TV so it doesn’t crop the top and bottom of the image displayed rendering the lower control buttons useless.. I’ve tried all screen resolutions on the tv and still cropped buttons.

Edit: Changed TV setting to “THX Cinema” and now display fully viewable.

I will explore more functions in the coming days but I have a feeling I might be downgrading back to V3.4.96 build 170921


RE: input verification code
Phil, I activated the HiK-Connect service just to make sure the unit was fully supported then disabled it and now setup via port forwarding without the need for a encryption code.
 

Attachments

Last edited:

Phil

Administrator
Staff member
Messages
1,691
Likes
127
Points
63
Thread starter #12
Glad you cracked it - Well Done.
Thanks for sharing your experience.
 

malford

New Member
Messages
20
Likes
10
Points
3
#13
Today I rolled back to V3.4.96 build 170921 with no issues.
V4.0 to me isn’t quite ready yet and seems cluttered and less productive, so I’ll revisit when the next version is ready.

Great forum Phil and thanks for accepting me :)
 
Messages
6
Likes
3
Points
3
#14
Glad to see it was not only me that has a user account password thing .. tho my one was the 2nd account was the password for the 1st account so the name was wrong.

I am sticking with v4 as its installed working.

Just have to get used to the new way.

Richard
 

gazwas

New Member
Messages
16
Likes
5
Points
3
#15
I've only just got my NVR and that came with V3.4.95 firmware. As you do in all the excitement of a new toy I updated the firmware to V4. However, even though I'd only spent a few hours using V3 it felt much better to use and certainly much nicer to look at. I also noticed that the remote no longer works to adjust any settings in V4 and where a mouse used to be an optional extra, now its a necessity. Seems like a stupid decision considering the only time you'll ever use the NVR interface is when hooked up locally to a monitor. Thankfully the web interface is unchanged and a much better looking way to interact with the NVR.

Hopefully things will improve with V4 as I don't think its quite ready and as no obvious (to me) features were added I'd recommend sticking with V3 especially if you use the NVR with a TV/monitor.
 

Phil

Administrator
Staff member
Messages
1,691
Likes
127
Points
63
Thread starter #16
Thanks for all the feedback on this.
I know that other users find the feedback useful, but I have to say that I do too.
I tend to pretty much always access our NVRs from my PC/browser - I'd assumed that people who use a direct-connected monitor more routinely would find the updates in V4 more beneficial - it seems not :(
 
Last edited:
Messages
4
Likes
1
Points
3
#17
Hi Same problem as Malford. No more possible to disable Stream Encryption (V3.4.96 build 170921 or V4)
In fact, i have installed V4, got the problem, went back to V3.4.96 but the problem is still there. It is possible to untick the "Enable Stream Encryption Option" on the screen connected to the NVR, but it is automatically reset on.
As mentioned by Phil above, when going back to V3.4.96, all nvr options were lost and need to be reintroduced.:(
 
Messages
4
Likes
1
Points
3
#18
It seems no more possible to disable encrypted streaming (V4 or V3.4.96 build 170921). When I untick « Enable Stream Encryption » (navigate to Configuration -> Network -> Access Platform on the screen attached to the NVR) and apply, it is ticked again at next NVR reboot. Moreover,even when unsticked in an ongoing NVR session, the stream key continues to be required to be able to visualise a cam.

After several trials, the situation I reached is the following :
  1. Browser access : once the stream key is introduced in the « Local panel », it is kept on the same PC . Thus so fine.
  2. On the I-phone app IVMS-4500, in the devices tab, it is possible to introduce the stream key once for a NVR device to clear all cams (as explained in the IVMS-4500 help) and it is kept once done. So fine.
  3. The most difficult situation was with IVMS-4200. Since the behaviour was erratic, I decided to deinstall my version and to completely reinstall V2.7.0.10:
  • For viewing cams from a NVR through Hik-connect, there is an interesting change in this version. When I click on a Hik-connect type NVR, all cams appeared on the screen with a blank field ready for stream key introduction. Moreover, once the key is introduced for one cam , all the others on the NVR are cleared ! The key is kept in memory. So simple and fine.
  • For viewing cams from a nvr added as online device (local lan), it is necessary to introduce the stream key for each cam in the group tab of the device management. But, now it is also kept in memory. So fine. Unfortunate that the same GUI as for Hik-Connect type device is not working.
  • For viewing cams from a NVR through its Dyndns address, same as for online device applies.
I find it strange that a stream key has to be provided even for cam output that is not going through hikvision server.

It is also even strange for me why the possibility to disable stream encryption is no more working. (I notice that it was also highlighted by malford in this topic). Of course, once the verification code is introduced everywhere, it corresponds to a higher level of security (double ID to be provided). But, I would prefer to be able to decide myself about it. ;)
 
Messages
3
Likes
0
Points
1
#19
Hi I have problem with this new firmware i have 2 nvr with firmware V3.4.91build 161220 i upgrade it to V4.1.03_180103 directly
now nvr login with unknown language for user name and did not accept password
i try to login with u-boot it work but i can`t restart nvr because it go back to with problem
 

Attachments

Status
Not open for further replies.
Top