01304 827609 info@use-ip.co.uk Find us

Firmware Latest HikVision Firmware for K-Series [76 77 86 NI-K2 K4 K8] NVRs - V4.30.005 build200628 (V4 Lite with E-UI)

sdolenec

New Member
Messages
3
Points
1
NVR DS 7608NI-K2/8P

In V3 this settings was working (used to read alarm data in Home Assistant).
After update to V4 not working because probably this is missing..
 

pdampier

New Member
Messages
15
Points
1
I have DS-7608NI-K2 / 8P running V4.21.005 build 190509 and all is working fine.

I am a firm believer in moving forward on firmware but saw the comments about about it reseting the NVR.

I don't mind reconfiguring as I only have 6 cameras and not a complex set up however - With respect to passwords on the NVR or the Hikvision Cameras is there anything I need to do first? For example if it resets the NVR box will the newly reset NVR box work with my cameras or are the cameras now locked out due to it etc?
 

sdolenec

New Member
Messages
3
Points
1
Never had problem with any setting reset neither to random NVR reset. All settings was the same as in V3 on upgrade FW.. Only HikVision-CGI setting missing.. Overal V4 is much faster for me (7 cameras)..
 

Dan

Administrator
Staff member
Messages
1,056
Points
63
I have just shared this new post which is linked below after a couple of users reported issues/bugs after updating to v4.30.005, as the post says the linking factor appeared to be they all had updated from v4.21.005 and Hikvision has confirmed that this may be what is causing the bugs those users are experiencing.


I will also add a note to the top of the original post in this thread to make users aware of the potential reset risk, we have updated an NVR here in our office to this firmware and it did not reset so it is not clear why some reset and others don't.

@pdampier if you have directly connected Hikvision cameras and you reactivate/setup your NVR with the same password details when you reset it then the cameras should reconnect without a problem, if they are remotely connected to the NVR over your local network you may have to go through and set each channel back to manual with each cameras IP address as by default all channels are set to plug & play for directly connected cameras.
 
Last edited by a moderator:

ben_57_f

New Member
Messages
2
Points
3
Like mantonl, on my NVR the motion detection keeps turning on the "notify surveillance centre" on all 8 cameras on my DS-7608NI-K2/8P with the V4.30.005 build 200628 firmware.
It happens everyday at midnight. Hikvision support suggested to rollback the firmware.

I checked the logs, there's a remote server changing the settings (Sorry the NVR is in French) :

Code:
204    2020-07-30 00:00:00    Fonctionnement    Ezviz Alarm Paramaters Config.    EZVIZ_9d1b    99.80.155.28    Commutateur d’armement rapide : Activé 
205    2020-07-30 00:00:00    Fonctionnement    Ezviz Alarm Paramaters Config.    EZVIZ_9d1b    34.246.27.13    Commutateur de notification d’alarme : Activé
Canal d’armement : 0
Période d’armement:
    Lun.
        00:00-23:59 
    Mar.
        00:00-23:59 
    Mer.
        00:00-23:59 
    Jeu.
        00:00-23:59 
    Ven.
        00:00-23:59 
    Sam.
        00:00-23:59 
    Dim.
        00:00-23:59

I'm waiting on Hikvision support to provide more information on the issue.

And I'll disable platform access tonight to see if it makes a difference.
 

mantonl

New Member
Messages
12
Points
3
Like mantonl, on my NVR the motion detection keeps turning on the "notify surveillance centre" on all 8 cameras on my DS-7608NI-K2/8P with the V4.30.005 build 200628 firmware.
It happens everyday at midnight. Hikvision support suggested to rollback the firmware.

I checked the logs, there's a remote server changing the settings (Sorry the NVR is in French) :

Code:
204    2020-07-30 00:00:00    Fonctionnement    Ezviz Alarm Paramaters Config.    EZVIZ_9d1b    99.80.155.28    Commutateur d’armement rapide : Activé
205    2020-07-30 00:00:00    Fonctionnement    Ezviz Alarm Paramaters Config.    EZVIZ_9d1b    34.246.27.13    Commutateur de notification d’alarme : Activé
Canal d’armement : 0
Période d’armement:
    Lun.
        00:00-23:59
    Mar.
        00:00-23:59
    Mer.
        00:00-23:59
    Jeu.
        00:00-23:59
    Ven.
        00:00-23:59
    Sam.
        00:00-23:59
    Dim.
        00:00-23:59

I'm waiting on Hikvision support to provide more information on the issue.

And I'll disable platform access tonight to see if it makes a difference.
Hi Ben, I've got around that issue at the moment on the 3 NVR's I've upgraded to V4.30.005 build 200628 firmware. I'm only using the "Smart Events" for motion detection and I've cleared the time schedule for every camera on the "Events" so although it still switches on the "Notify Surveillance Centre" for all 8 cameras, it doesn't sent any alerts to our phones and tablets as the schedule tells it not to. I don't have this issue with the "Smart Events" as on my NVR at home I have it set to send events on 3 cameras only and that's working fine. Hopefully this bug will be address in the next release of the firmware and using this "Get Around" saves me having to roll the firmware back on the ones I have already upgraded and I still have another 5 NVR's to do yet. Lee...
 

Woodyz82

Member
Messages
50
Points
8
Do you mean your NVR at home doesn’t suffer from this on the same firmware?

I’m wanting to make the jump to the V4, but nervous with the bugs.

Can you explain a bit more about the work around - not quite fully understanding what you mean.
 

mantonl

New Member
Messages
12
Points
3
Do you mean your NVR at home doesn’t suffer from this on the same firmware?

I’m wanting to make the jump to the V4, but nervous with the bugs.

Can you explain a bit more about the work around - not quite fully understanding what you mean.
Hi, (apologies if I'm explaining something you already know about and how to set up) my NVR running with V4.30.005 build 200628 firmware has 2 sets of event triggers Normal and Smart. The normal events is the bit with the issue and its the same on all 4 NVR's that I've upgraded so far. The setting for the Smart and Normal events are basically the same and for each camera and you can set an area that when something enters, it triggers and event. This event can be any combination of a buzzer inside the nvr, a screen popup, an email and an alert sent to a Hikvision app running on a phone or tablet (called on the NVR "Notify Surveillance Centre"). Also I can set the time frame for each camera to run the options that have been set. This is a 24hour 7 day schedule and its this alert that has the problem. In my case I have 8 cameras and what the firmware does on its own is turn on the alert to my phone on all 8 cameras for the Normal events. So my phone goes crazy with alerts every few seconds. If you uncheck the option on all 8 cameras, 24 hours later its re-enabled itself again and again my phone and tablet goes mad with alerts. So to get around this I set the schedule time period that I want to send the alerts to zero for every day on every camera and so even though the alerts are set to send to my phone, they don't because the schedule says not to. Basically is a work around and as long as I don't use the Normal events, this is now not a problem for me. The Smart Events is the same setup but the alerts to my phone are only ticked on the 3 cameras I want and the firmware leaves the rest alone. I have tried upgrading from different versions of the firmware, doing factory resets between each upgrade and nothing has made any different on all 4 NVR's and all 4 are suffering from the same issue and so I've used this workaround on them all for now until we get the next version of the firmware when hopefully this issue will be addressed. Hope my waffling has made it a bit clearer for you. Lee...
 

Woodyz82

Member
Messages
50
Points
8
Thanks a lot - yes it has. I’ve not long had my setup and I’m sat on V3, wondering if I should jump to V4. All makes sense - just not sure about the setting in time alerts to set to zero- but can’t say I have been into it ghat deep.

I need to set my alerts up this weekend as going away next week. I record continuous 24/7 across x4 cameras and I have disabled the standard motion detection as it just goes off all the time as alerts on the NVR which is obvious it would given it picks up tress and cars! I read even setting the area to not pick up certain areas still gives lots of false alerts. I plan to setup just smart events for a line crossing detection and intrusion detection on the cameras (well I have two on the front of the house which pan across each other, so will only set up this one one of those or I will get double alerts, then the same on he back garden and down the side of the house.

Will set it just to notify surveillance centre so alerts come to my phone via Hik Connect.

So would this bug affect what I plan to do?
 

mantonl

New Member
Messages
12
Points
3
Thanks a lot - yes it has. I’ve not long had my setup and I’m sat on V3, wondering if I should jump to V4. All makes sense - just not sure about the setting in time alerts to set to zero- but can’t say I have been into it ghat deep.

I need to set my alerts up this weekend as going away next week. I record continuous 24/7 across x4 cameras and I have disabled the standard motion detection as it just goes off all the time as alerts on the NVR which is obvious it would given it picks up tress and cars! I read even setting the area to not pick up certain areas still gives lots of false alerts. I plan to setup just smart events for a line crossing detection and intrusion detection on the cameras (well I have two on the front of the house which pan across each other, so will only set up this one one of those or I will get double alerts, then the same on he back garden and down the side of the house.

Will set it just to notify surveillance centre so alerts come to my phone via Hik Connect.

So would this bug affect what I plan to do?
Hi, yes it would, just make sure you delete the Normal Events schedule for each camera and then you will be fine using the Smart Events line crossing, I've attached a pic of mine showing camera 1 and you would need to clear the schedule for as many cameras as you have. Lee...
 

Attachments

Woodyz82

Member
Messages
50
Points
8
Thank you! I was just going to knock off motion detection on normal events - Would that have the same effect?

Might be worth just staying in V3 and waiting for the next firmware release? Any benefits in me jumping to V4?
 

Woodyz82

Member
Messages
50
Points
8
Hi, yes it would, just make sure you delete the Normal Events schedule for each camera and then you will be fine using the Smart Events line crossing, I've attached a pic of mine showing camera 1 and you would need to clear the schedule for as many cameras as you have. Lee...
Jumped to V4 today, didn’t lose any settings and no problems as yet. Much slicker and much more modern look.

One thing I thought you could try in reference to your linkage / notify surveillance centre issue that I noticed today was that this is turned off on my NVR settings, but when I log into the camera it is turned on there. Just a thought - could it be getting updated from the camera to the NVR? Maybe log into the camera and turn it all off and see what happens. I will keep an eye on mine in next day and see if that changes.
 
Top